Ticket #98 (closed enhancement: worksforme)

Opened 4 years ago

Last modified 3 years ago

selecting multiple subjects in study create wizard works very bad

Reported by: kees.vanbochove@… Owned by: j.a.m.wesbeek@…
Priority: trivial Milestone: 0.6.1
Component: Study create wizard Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

- please allow deselect by clicking anywhere
- allow using SHIFT to select multiple rows
- a 'select all' would come in handy
- bug: when a certain field is selected, select multiple and then re-select the item from the drop down does not work (onChange vs onClick?)
- bug: sometimes Subject 1 disappears?!
- the id column should be removed!

Change History

Changed 4 years ago by leny.vanwijk@…

If you in tab 3.Subjects want to attribute a certain feature in a dropdown menu to multiple subjects by selecting multiple subjects, after selecting the feature for one subject only that particular subject obtains the feature. For the other selected subjects you need to press Enter en then all subjects that are selected have the chosen feature.
If you want to attribute a certain feature to all subjects that has to be written in a text field (features like GenoType?)all subjects that were selected get the description immediately.

Changed 4 years ago by leny.vanwijk@…

It is possible to select all subjects:
us ctrl-clicking and dragging a selection together. If you keep ctrl and drag a selection, you can slide down and drag an additional selection. In this way it is possiible to select all subjects and template fields can be filled in by filling just one.

Changed 4 years ago by leny.vanwijk@…

bug: sometimes a group of selected subjects does not show and get the word I type in one of the fields of a subject. Although I selected some subjects, only the one I used to fill in a field got the description I typed, the other subjects do not show the description at all (even after pressing Enter). I cannot reproduce this just when I want, it sometimes happens and I don't know what circumstances are important. I used internet explorer 7 and windows xp.

After deselecting and selecting again it works as normal.

Changed 4 years ago by kees.vanbochove@…

Select all is most important

Changed 4 years ago by kees.vanbochove@…

Select all is most important

Changed 4 years ago by j.a.m.wesbeek@…

The Selectable functionality is implemented by using the jquery-ui Framework which implies we rely on the functionality it provides. The Selectable implemention unfortunaly does not provide programmatical hooks to interact making a 'select all' functionality impossible (or at least, very hard) to implement.

However, a lot of these requests are in development / in planning by the jQuery-ui developers (see:  http://wiki.jqueryui.com/Selectable ). So I think the best approach is to wait until they get implemented in jquery-ui.

Bug: unable to reproduce
ID: true, but this still in there for development purposes... will be removed in the future...

Next time: please seperate these issues in separate bugs as now I have to resolve and / or add feedback on several issues in one issue... What if one of them is resolved and the rest isn't?

Changed 4 years ago by j.a.m.wesbeek@…

Lowering priority to 1 as we depend on a third party to improve a library...

Changed 3 years ago by business@…

'Select all' functionality is now in place, but many times it doesn't work in Firefox. Seems to be some kind of Javascript bug?

Changed 3 years ago by business@…

  • milestone set to 0.6.1

Changed 3 years ago by j.a.m.wesbeek@…

  • status changed from accepted to closed
  • resolution set to worksforme
Note: See TracTickets for help on using tickets.