Ticket #84 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

add ontologies chooser to template editor

Reported by: kees.vanbochove@… Owned by: kees.vanbochove@…
Priority: major Milestone:
Component: Export functionality Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

For ONTOLOGYTERM fields, the ontologies that the terms should come from are defined in the 'ontologies' collection of that TemplateField?.

Make a user interface in the template editor to choose these (can be multiple), starting from the ontologies that are already in the database, given as a list of ontology names, but also give the possibility for 'add more'.

In the add screen, there should be two options:
* Add by BioPortal? Ontology ID
* Add by term search -> display an ontology search box tied to ALL ontologies and then extract the ontology ncboId from the chosen term. **
(If the second one is difficult, only implement the first)

For the first method you can use the static getBioPortalOntology method in Ontology, just like is done in the integration test gscf.OntologyTests?.testAddBioPortalOntology for adding the new ontology to the database.

** This might be difficult since you get only the ncboVersionedId via the XML. So you would have to implement also a getBioPortalOntologyByVersionedId(ncboVersionedId). This might even involve getting all ontologies with os.getOntologies() and then do find { it.id == ncboVersionedId }, which would work but is very inefficient.
See for Javadoc of Ontocat:http://ontocat.sourceforge.net/doc/index.html

Change History

Changed 4 years ago by robert@…

I have added the possibility to search for ontologies. I'm not really sure whether I have implemented it the way you described it, but I think it works OK.

Changed 4 years ago by kees.vanbochove@…

it's perfect!

Changed 3 years ago by business@…

  • status changed from closed to reopened
  • type changed from enhancement to defect
  • component set to Export functionality

At this point somehow it doesn't work any more. If I want to add an ontology by NCBO ID (I tested 1494, described at  http://bioportal.bioontology.org/ontologies/42764), you get the error message: Could not add ontology: No ID given.

When adding via term, you see a long list of <span... which makes is difficult to read.

Changed 3 years ago by robert@…

  • status changed from reopened to assigned
  • owner changed from robert@… to kees.vanbochove@…

This bug is fixed in the current version. Also, the addition of ontologies by term is improved.

Changed 3 years ago by business@…

  • status changed from assigned to closed
  • resolution set to fixed

Confirmed fixed.

Note: See TracTickets for help on using tickets.