Ticket #519 (closed defect: invalid)

Opened 2 years ago

Last modified 2 years ago

Visualization module should be able to deal with null values

Reported by: business@… Owned by: business@…
Priority: major Milestone: 0.8.6
Component: Unknown Version: 0.8.3
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

Barchart and linechart are not able to cope with null data from metabolomics module:

numValues=22
Returndata: 
type=barchart
xaxis={title=name, unit=, type=categorical}
yaxis={title=C10:0 Fatty acid                                  , unit=, type=numerical}
groupaxis={title=null, unit=null, type=numerical}
series=[{name=count, x=[1_B, 1_A, 2_B, 2_A, 3_B, 3_A, 4_B, 4_A, 5_B, 5_A, 6_B, 6_A, 7_B, 7_A, 8_B, 8_A, 9_B, 9_A, 10_B, 10_A, 11_B, 11_A], y=[null, 1.1000000000000001, null, 1.1000000000000001, null, 1.1000000000000001, null, 1.1000000000000001, null, 1.1000000000000001, null, 1.1000000000000001, null, 1.1000000000000001, null, 1.1000000000000001, null, 1.1000000000000001, null, 1.1000000000000001, null, null]}]

Change History

Changed 2 years ago by robert@…

  • owner changed from robert@… to business@…
  • status changed from new to assigned

This seems to be solved now locally. however, I can't access any studies in the metabolomics module. Please test whether it works again.

Changed 2 years ago by business@…

  • status changed from assigned to closed
  • resolution set to invalid

Doesn't work, but this seems to be caused by the fact that the metabolomics module serves the REST data as strings instead of numbers.

Note: See TracTickets for help on using tickets.