Ticket #51 (closed defect: fixed)

Opened 4 years ago

Last modified 2 years ago

adding new ontology terms does not work (also on ci.nmcdsp.org)

Reported by: kees.vanbochove@… Owned by: jildau.bouwman@…
Priority: major Milestone: 0.8.6
Component: Ajaxflow Plugin Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description (last modified by jildau.bouwman@…) (diff)

Test with ontologyID 1314
Error message:

Could not add ontology: <html>

<head>

<title>Grails Runtime Exception</title>
<style type="text/css">

.message {

border: 1px solid black;
padding: 5px;
background-color:#E9E9E9;

}
.stack {

border: 1px solid black;
padding: 5px;
overflow:auto;
height: 300px;

}
.snippet {

padding: 5px;
background-color:white;
border:1px solid black;
margin:3px;
font-family:courier;

}

</style>

</head>

<body>

<h1>Grails Runtime Exception</h1>
<h2>Error Details</h2>

<div class="message">

<strong>Error 500:</strong> Executing action [addOntologyById] of controller [org.dbnp.gdt.TemplateEditorController?] in plugin [gdt] caused exception: Could not execute JDBC batch update; SQL [insert into ontology (version, date_created, description, last_updated, name, ncbo_id, ncbo_versioned_id, url, version_number, id) values (?, ?, ?, ?, ?, ?, ?, ?, ?, ?)]; nested exception is org.hibernate.exception.DataException?: Could not execute JDBC batch update<br/>
<strong>Servlet:</strong> grails<br/>
<strong>URI:</strong> /gscf-0.8.6-ci/grails/templateEditor/addOntologyById.dispatch<br/>


<strong>Exception Message:</strong> Batch entry 0 insert into ontology (version, date_created, description, last_updated, name, ncbo_id, ncbo_versioned_id, url, version_number, id) values ('0', '2012-05-03 11:02:38.551000 +02:00:00', 'The Cell Line Ontology (CLO) is a community-based ontology in domain of biological cell lines with a focus on permanent cell lines from culture collections. Upper ontology structures that frame the skeleton of CLO include Basic Formal Ontology and Relation Ontology. Cell lines contained in CLO are associated with terms from other ontologies such as Cell Type Ontology, NCBI Taxonomy, and Ontology for Biomedical Investigation. A common design pattern for the cell line is used to model cell lines and their attributes, the Jurkat cell line provides ane xample. Currently CLO contains over 36,000 cell line entries obtained from ATCC, HyperCLDB, Coriell, and bymanual curation. The cell lines are derived from 194 cell types, 656 anatomical entries, and 217 organisms. The OWL-based CLO is machine-readable and can be used in various applications.', '2012-05-03 11:02:38.551000 +02:00:00', 'Cell Line Ontology', '1314', '45376', ' http://bioportal.bioontology.org/ontologies/45376', '2.0.27', '4421') was aborted. Call getNextException to see the cause. <br />
<strong>Caused by:</strong> Batch entry 0 insert into ontology (version, date_created, description, last_updated, name, ncbo_id, ncbo_versioned_id, url, version_number, id) values ('0', '2012-05-03 11:02:38.551000 +02:00:00', 'The Cell Line Ontology (CLO) is a community-based ontology in domain of biological cell lines with a focus on permanent cell lines from culture collections. Upper ontology structures that frame the skeleton of CLO include Basic Formal Ontology and Relation Ontology. Cell lines contained in CLO are associated with terms from other ontologies such as Cell Type Ontology, NCBI Taxonomy, and Ontology for Biomedical Investigation. A common design pattern for the cell line is used to model cell lines and their attributes, the Jurkat cell line provides ane xample. Currently CLO contains over 36,000 cell line entries obtained from ATCC, HyperCLDB, Coriell, and bymanual curation. The cell lines are derived from 194 cell types, 656 anatomical entries, and 217 organisms. The OWL-based CLO is machine-readable and can be used in various applications.', '2012-05-03 11:02:38.551000 +02:00:00', 'Cell Line Ontology', '1314', '45376', ' http://bioportal.bioontology.org/ontologies/45376', '2.0.27', '4421') was aborted. Call getNextException to see the cause. <br />
<strong>Class:</strong> TemplateEditorController? <br />
<strong>At Line:</strong> [824] <br />
<strong>Code Snippet:</strong><br />
<div class="snippet">


</div>


</div>


<h2>Stack Trace</h2>
<div class="stack">

<pre>java.sql.BatchUpdateException?: Batch entry 0 insert into ontology (version, date_created, description, last_updated, name, ncbo_id, ncbo_versioned_id, url, version_number, id) values ('0', '2012-05-03 11:02:38.551000 +02:00:00', 'The Cell Line Ontology (CLO) is a community-based ontology in domain of biological cell lines with a focus on permanent cell lines from culture collections. Upper ontology structures that frame the skeleton of CLO include Basic Formal Ontology and Relation Ontology. Cell lines contained in CLO are associated with terms from other ontologies such as Cell Type Ontology, NCBI Taxonomy, and Ontology for Biomedical Investigation. A common design pattern for the cell line is used to model cell lines and their attributes, the Jurkat cell line provides ane xample. Currently CLO contains over 36,000 cell line entries obtained from ATCC, HyperCLDB, Coriell, and bymanual curation. The cell lines are derived from 194 cell types, 656 anatomical entries, and 217 organisms. The OWL-based CLO is machine-readable and can be used in various applications.', '2012-05-03 11:02:38.551000 +02:00:00', 'Cell Line Ontology', '1314', '45376', ' http://bioportal.bioontology.org/ontologies/45376', '2.0.27', '4421') was aborted. Call getNextException to see the cause.

<br/> at org.postgresql.jdbc2.AbstractJdbc?2Statement$BatchResultHandler?.handleError(AbstractJdbc?2Statement.java:2621)
<br/> at org.postgresql.core.v3.QueryExecutorImpl?.processResults(QueryExecutorImpl?.java:1837)
<br/> at org.postgresql.core.v3.QueryExecutorImpl?.execute(QueryExecutorImpl?.java:407)
<br/> at org.postgresql.jdbc2.AbstractJdbc?2Statement.executeBatch(AbstractJdbc?2Statement.java:2754)
<br/> at org.apache.commons.dbcp.DelegatingStatement?.executeBatch(DelegatingStatement?.java:297)
<br/> at org.apache.commons.dbcp.DelegatingStatement?.executeBatch(DelegatingStatement?.java:297)
<br/> at net.bull.javamelody.JdbcWrapper?.doExecute(JdbcWrapper?.java:342)
<br/> at net.bull.javamelody.JdbcWrapper?$StatementInvocationHandler?.invoke(JdbcWrapper?.java:129)
<br/> at net.bull.javamelody.JdbcWrapper?$DelegatingInvocationHandler?.invoke(JdbcWrapper?.java:232)
<br/> at $Proxy19.executeBatch(Unknown Source)
<br/> at org.dbnp.gdt.TemplateEditorController?$_closure17.doCall(TemplateEditorController?.groovy:824)
<br/> at org.dbnp.gdt.TemplateEditorController?$_closure17.doCall(TemplateEditorController?.groovy)
<br/> at net.bull.javamelody.JspWrapper?.invoke(JspWrapper?.java:117)
<br/> at net.bull.javamelody.JdbcWrapper?$DelegatingInvocationHandler?.invoke(JdbcWrapper?.java:232)
<br/> at $Proxy44.forward(Unknown Source)
<br/> at net.bull.javamelody.MonitoringFilter?.doFilter(MonitoringFilter?.java:185)
<br/> at net.bull.javamelody.MonitoringFilter?.doFilter(MonitoringFilter?.java:159)
<br/> at org.apache.jk.server.JkCoyoteHandler?.invoke(JkCoyoteHandler?.java:190)
<br/> at org.apache.jk.common.HandlerRequest?.invoke(HandlerRequest?.java:291)
<br/> at org.apache.jk.common.ChannelSocket?.invoke(ChannelSocket?.java:774)
<br/> at org.apache.jk.common.ChannelSocket?.processConnection(ChannelSocket?.java:703)
<br/> at org.apache.jk.common.ChannelSocket?$SocketConnection?.runIt(ChannelSocket?.java:896)
<br/> at java.lang.Thread.run(Thread.java:662)
<br/></pre>

</div>


</body>

</html>

Change History

Changed 4 years ago by j.a.m.wesbeek@…

This was already fixed about two weeks ago

Changed 2 years ago by jildau.bouwman@…

  • status changed from closed to reopened
  • resolution fixed deleted
  • component set to Ajaxflow Plugin
  • milestone set to 0.8.6

Changed 2 years ago by jildau.bouwman@…

  • owner changed from vinlud@… to jildau.bouwman@…
  • status changed from reopened to assigned
  • description modified (diff)
  • summary changed from adding new ontology terms (species) does not work in production environment to adding new ontology terms does not work (also on ci.nmcdsp.org)

Changed 2 years ago by work@…

Example query that fails:

insert into ontology (version, date_created, description, last_updated, name, ncbo_id, ncbo_versioned_id, url, version_number, id) values ('0', '2012-05-08 16:23:07.937000 +02:00:00', 'The Cell Line Ontology (CLO) is a community-based ontology in domain of biological cell lines with a focus on permanent cell lines from culture collections. Upper ontology structures that frame the skeleton of CLO include Basic Formal Ontology and Relation Ontology. Cell lines contained in CLO are associated with terms from other ontologies such as Cell Type Ontology, NCBI Taxonomy, and Ontology for Biomedical Investigation. A common design pattern for the cell line is used to model cell lines and their attributes, the Jurkat cell line provides ane xample.  Currently CLO contains over 36,000 cell line entries obtained from ATCC, HyperCLDB, Coriell, and bymanual curation. The cell lines are derived from 194 cell types, 656 anatomical entries, and 217 organisms. The OWL-based CLO is machine-readable and can be used in various applications.', '2012-05-08 16:23:07.937000 +02:00:00', 'Cell Line Ontology', '1314', '45376', 'http://bioportal.bioontology.org/ontologies/45376', '2.0.27', '4423') 

When executing the query manually, the error thrown is:

Error : ERROR:  value too long for type character varying(255)

Changed 2 years ago by work@…

  • status changed from assigned to closed
  • resolution set to fixed

Resolved in r2228 and  r783

Changed 2 years ago by work@…

links was broken --> fixed in r2228 and  gdt r783

Note: See TracTickets for help on using tickets.