Ticket #490 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

StaleObjectStateException when adding new assay with samples to study

Reported by: s.h.sikkema@… Owned by: work@…
Priority: major Milestone: 0.8.6
Component: Study create/edit wizard Version: 0.8.3
Keywords: Cc:
Hardware: Operating system:
Product: URL:


ERROR events.PatchedDefaultFlushEventListener? - Could not synchronize database state with session
org.hibernate.StaleObjectStateException?: Row was updated or deleted by another transaction (or unsaved-value mapping was incorrect): [dbnp.studycapturing.Study#3]

Should be reproducible by following these steps:

  • create a study
  • upload samples via gdtImporter
  • switch to admin
  • add new module
  • switch to user
  • create assay for new module
  • add all samples
  • save ...

Still occurs when trying to save again (not a one-time thing)


  • log out and back in
  • edit assays
  • notice that the assay is already there but no samples added
  • add samples to assay
  • quick save
  • voila! it works ...

Change History

comment:1 Changed 4 years ago by business@…

  • Milestone changed from 0.8.4 to 0.8.6

Check if reproducible if users are not switched and module is not added.

comment:2 Changed 4 years ago by work@…

  • Status changed from new to closed
  • Resolution set to worksforme

cannot reproduce

Note: See TracTickets for help on using tickets.