Ticket #477 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Sample importer hangs on last step when event group names already exist

Reported by: business@… Owned by: business@…
Priority: major Milestone: 0.8.4
Component: Import wizard Version: 0.8.3
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

If you import samples, attach them to existing subjects, and the generated event group names already exist in the study, the importer fails with an error in the last step:

2011-06-01 16:32:48,726 [http-10080-4] ERROR StackTrace  - Sanitizing stacktrace:
org.springframework.dao.DataIntegrityViolationException: Could not execute JDBC batch update; SQL [insert into event_group (version, name, parent_id, event_groups_idx, id) values (?, ?, ?, ?, ?)]; constraint [null]; nested exception is org.hibernate.exception.ConstraintViolationException: Could not execute JDBC batch update
	at org.dbnp.gdtimporter.GdtImporterService$$EnhancerByCGLIB$$fcab5876.attachSamplesToSubjects(<generated>)
	at org.dbnp.gdtimporter.GdtImporterService$attachSamplesToSubjects.call(Unknown Source)
	at org.dbnp.gdtimporter.GdtImporterController$_closure2_closure28_closure46.doCall(GdtImporterController.groovy:340)
	at java.lang.Thread.run(Thread.java:662)
Caused by: org.hibernate.exception.ConstraintViolationException: Could not execute JDBC batch update
	... 4 more
Caused by: java.sql.BatchUpdateException: Batch entry 0 insert into event_group (version, name, parent_id, event_groups_idx, id) values (0, Sampling_Blood_12w, 10, 6, 8200) was aborted.  Call getNextException to see the cause.
	at org.postgresql.jdbc2.AbstractJdbc2Statement$BatchResultHandler.handleError(AbstractJdbc2Statement.java:2533)
	at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1317)
	at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:350)
	at org.postgresql.jdbc2.AbstractJdbc2Statement.executeBatch(AbstractJdbc2Statement.java:2592)
	at org.apache.commons.dbcp.DelegatingStatement.executeBatch(DelegatingStatement.java:297)
	at org.apache.commons.dbcp.DelegatingStatement.executeBatch(DelegatingStatement.java:297)

Change History

Changed 3 years ago by s.h.sikkema@…

  • owner changed from s.h.sikkema@… to business@…
  • status changed from new to assigned

Changed 3 years ago by business@…

  • status changed from assigned to closed
  • resolution set to duplicate

Hard to test now that the wizard also does a better job of checking for duplicates and already existing samples, but this will be solved anyway when #463 is implemented.

Note: See TracTickets for help on using tickets.