Ticket #468 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Please wait... after editing contacts takes quite long

Reported by: business@… Owned by: business@…
Priority: minor Milestone: 0.8.4
Component: Study create/edit wizard Version: 0.8.2
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

If you edit contacts in the wizard and close the popup, you get Please Wait... for more than 15 seconds. This is annoying, especially when you have to add multiple people. Seen on NMC production instance.

Change History

Changed 3 years ago by work@…

  • milestone changed from 0.8.3 to 0.8.4

Changed 3 years ago by work@…

  • status changed from new to assigned
  • owner changed from work@… to business@…

Yeah, but unfortunately we cannot do a lot about that... This is caused by the study instance being really big. We should profile what Grails is really doing with the study instance... perhaps it's doing a lot of database stuff underwater?

Contacts works pretty much on it's own, creating contact instances. Perhaps Hibernate session gets refreshed and hence causing the big study instance to be refreshed as well?

Changed 3 years ago by business@…

  • status changed from assigned to closed
  • resolution set to fixed

This problem is solved now, was probably caused by the other GSCF instances that were running in the production Tomcat.

Note: See TracTickets for help on using tickets.