Ticket #461 (closed defect: worksforme)

Opened 3 years ago

Last modified 3 years ago

Error when searching on template

Reported by: business@… Owned by: robert@…
Priority: major Milestone: 0.8.3
Component: Unknown Version: 0.8.2
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

If I search on CI (logged in as user) with these criteria:

* Sample.template contains blood
* Search on Samples

I get the following error:

gscf 0.8.2 ci build
revision 	: 1881
Grails version 	: 1.3.7
deployed 	: Wed May 25 16:11:32 2011
build age 	: 0d, 0h, 10m, 6s
hostname 	: nmcdsp.org
Grails Runtime Exception
Error Details
Error 500: Error processing GroovyPageView: null
Servlet: grails
URI: /gscf-0.8.2-ci/grails/advancedQuery/search.dispatch
Exception Message:
Caused by: Error processing GroovyPageView: null
Class: gsp_gscf_advancedQuerysampleresults_gsp
At Line: [116]
Code Snippet:
Stack Trace

org.codehaus.groovy.grails.web.pages.exceptions.GroovyPagesException: Error processing GroovyPageView: null

	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)

	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)

	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:774)

	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)

	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:896)

	at java.lang.Thread.run(Thread.java:662)

Caused by: java.lang.NullPointerException

	at dbnp.studycapturing.Sample$__clinit__closure2_closure4_closure5.doCall(Sample.groovy:98)

	at dbnp.studycapturing.Sample$__clinit__closure2_closure4.doCall(Sample.groovy:98)

	at dbnp.studycapturing.Sample.giveUUID(Sample.groovy:157)

	at dbnp.studycapturing.Sample$giveUUID.call(Unknown Source)

	at gsp_gscf_advancedQuerysampleresults_gsp$_run_closure2_closure4.doCall(gsp_gscf_advancedQuerysampleresults_gsp.groovy:79)

	at gsp_gscf_advancedQuerysampleresults_gsp$_run_closure2.doCall(gsp_gscf_advancedQuerysampleresults_gsp.groovy:67)

	at gsp_gscf_advancedQuerysampleresults_gsp$_run_closure2.doCall(gsp_gscf_advancedQuerysampleresults_gsp.groovy)

	at gsp_gscf_advancedQuerysampleresults_gsp.run(gsp_gscf_advancedQuerysampleresults_gsp.groovy:116)

	... 6 more

Change History

Changed 3 years ago by robert@…

  • status changed from new to closed
  • resolution set to worksforme

Can't reproduce this error

Note: See TracTickets for help on using tickets.