Ticket #457 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Query on Template results in exception

Reported by: business@… Owned by: business@…
Priority: major Milestone: 0.8.4
Component: Query Version: 0.8.1
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

Searching on sample template = Blood on CI results in:

Grails Runtime Exception
Error Details
Error 500: Executing action [search] of controller [dbnp.query.AdvancedQueryController] caused exception: unexpected token: null near line 1, column 40 [FROM dbnp.studycapturing.Sample sample null WHERE null and EXISTS( FROM sample.parent study WHERE study IN (:sampleparent) )]; nested exception is org.hibernate.hql.ast.QuerySyntaxException: unexpected token: null near line 1, column 40 [FROM dbnp.studycapturing.Sample sample null WHERE null and EXISTS( FROM sample.parent study WHERE study IN (:sampleparent) )]
Servlet: grails
URI: /gscf-0.8.1-ci/grails/advancedQuery/search.dispatch
Exception Message: unexpected token: null near line 1, column 40 [FROM dbnp.studycapturing.Sample sample null WHERE null and EXISTS( FROM sample.parent study WHERE study IN (:sampleparent) )]
Caused by: unexpected token: null near line 1, column 40 [FROM dbnp.studycapturing.Sample sample null WHERE null and EXISTS( FROM sample.parent study WHERE study IN (:sampleparent) )]
Class: AdvancedQueryController
At Line: [63]
Code Snippet:
Stack Trace

org.hibernate.hql.ast.QuerySyntaxException: unexpected token: null near line 1, column 40 [FROM dbnp.studycapturing.Sample sample null  WHERE null and  EXISTS( FROM sample.parent study WHERE study IN (:sampleparent) )]

	at $Proxy15.createQuery(Unknown Source)

	at dbnp.query.Search.executeSearch(Search.groovy:164)

	at dbnp.query.Search.execute(Search.groovy:115)

	at dbnp.query.Search$execute$0.callCurrent(Unknown Source)

	at dbnp.query.Search$execute$0.callCurrent(Unknown Source)

	at dbnp.query.Search.execute(Search.groovy:105)

	at dbnp.query.Search$execute.call(Unknown Source)

	at dbnp.query.Search$execute.call(Unknown Source)

	at dbnp.query.AdvancedQueryController$_closure2.doCall(AdvancedQueryController.groovy:63)

	at dbnp.query.AdvancedQueryController$_closure2.doCall(AdvancedQueryController.groovy)

	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)

	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)

	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:774)

	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)

	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:896)

	at java.lang.Thread.run(Thread.java:662)

Change History

Changed 3 years ago by robert@…

  • status changed from new to assigned
  • owner changed from robert@… to business@…

Solved in r1866. Please test again

Changed 3 years ago by work@…

  • milestone changed from 0.8.2 to 0.8.3

Changed 3 years ago by work@…

  • milestone changed from 0.8.3 to 0.8.4

Changed 3 years ago by business@…

  • status changed from assigned to closed
  • resolution set to fixed

Tested this, works now.

Note: See TracTickets for help on using tickets.