Ticket #443 (closed defect: wontfix)

Opened 3 years ago

Last modified 3 years ago

samples are created too early

Reported by: janneke@… Owned by: work@…
Priority: minor Milestone: Must have
Component: Study create/edit wizard Version: 0.8.1
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

Samples are not created when clicking 'next' in step 3, but earlier:

- eighter when I create a new samplingevent
- or when I clone a samplingevent

This gives the following problem,
I create a new bloodsample with starttime 3w
I clone this one and change starttime into 5w (see .png)
When I click next, 2 samples are created which have 3w and 3w_1 as sample name, instead of 3w and 5w (see 2.png)

This means that samples were already created when I cloned the sampling event.

Samples should be created when clicking 'next', because that allows editing starttimes

Attachments

2011_17mei_sample creation.png Download (20.2 KB) - added by janneke@… 3 years ago.
2011_17mei_sample creation2.png Download (17.5 KB) - added by janneke@… 3 years ago.
2011_17mei sample creation3.png Download (30.4 KB) - added by janneke@… 3 years ago.

Change History

Changed 3 years ago by janneke@…

Changed 3 years ago by janneke@…

Changed 3 years ago by janneke@…

oke, this becomes complex

When I now clone 5w, and change into 7w (now I have 3 sampling events (3w,5w,7w), and click next, next
The result is 3w, 5w, and 3w_1 (see 3.png)

The samplenames are indeed updated, but only the one that is cloned (in this case 5w)

Changed 3 years ago by janneke@…

Changed 3 years ago by janneke@…

I used study 00a2 on ci

Changed 3 years ago by janneke@…

This problem can be avoided, by first creating sampling events. Then click 'quick save'.
If I now continue to assigning subjects into groups and samples, samplenames are created correctly

Changed 3 years ago by work@…

Actually, this is by design. I won't go into technical details here but the logic of generating (or deleting) samples is always performed when 'something happens that will result in samples'.

E.g. adding a sampling event to an eventgroup that contains subject, adding subjects to an event group that contains sampling events, etcetera... This logic is incorporated into the subjects page, event page, event grouping page...

So actually, your problem is not with the fact that those samples are generated, but that the name of the samples is not what you expect it to be...

Changed 3 years ago by work@…

  • priority changed from major to minor
  • milestone changed from 0.8.2 to Must have

Changed 3 years ago by janneke@…

When I create a sampling event using the few steps above in the wizard step, then the samplenames are created correctly
So, in this case the samplenames are not made unique by adding _1, _2 etcetera.

Problem seems to be, when using the clone function and edit there starttime of sampling event.

Changed 3 years ago by work@…

  • status changed from new to closed
  • resolution set to wontfix

Currently, you can by importing your samples. The problem with this feature request is that samples are generated on the moment the should exist.

For example:

1. when you add a subject to an event group that has sampling event(s), at that moment also sample instances are created for those subject / samplingEvent relations
2. when you create a new sampling event and add it to a group that already contains subjects, automatically samples a generated for these subject / eventgroup relations.

This cannot be done at a later stage, as by design you are allowed to click through tabs and doing this differently might result in integrity errors in sample / event and eventgroup relations.

The thing with cloning samples is that obviously a clone has the same properties as the original, so if you clone it and add it to an eventgroup the samples will have the same names. If you first clone it, then change the properties. And at a later stage group it, the sample names should be as expected...

also see #408

Closing issue as it is mostly an issue of the order in creating and grouping by the user...

Note: See TracTickets for help on using tickets.