Ticket #435 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Runtime exception when going from the studywizard to the assay exporter

Reported by: robert@… Owned by: business@…
Priority: major Milestone: 0.8.1
Component: Unknown Version: 0.8.0
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

On CI:
- go to Create -> Edit Study
- choose from the menu Export -> Export data to excel
- click 'OK' on the popup

org.springframework.webflow.execution.FlowExecutionException: Exception thrown in state 'mainPage' of flow 'studyWizard/pages'

	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)

	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)

	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:774)

	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)

	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:896)

	at java.lang.Thread.run(Thread.java:662)

Caused by: java.lang.IllegalStateException: Exception occurred rendering view org.codehaus.groovy.grails.web.servlet.view.GroovyPageView: unnamed; URL [/WEB-INF/grails-app/views/studyWizard/index.gsp]

	... 6 more

Caused by: org.codehaus.groovy.grails.web.pages.exceptions.GroovyPagesException: Error processing GroovyPageView: Template not found for name [common/ajaxflow] and path [/assay/common/_ajaxflow.gsp] at /WEB-INF/grails-app/views/studyWizard/index.gsp:53

	... 6 more

Caused by: org.codehaus.groovy.grails.web.taglib.exceptions.GrailsTagException: Template not found for name [common/ajaxflow] and path [/assay/common/_ajaxflow.gsp] at /WEB-INF/grails-app/views/studyWizard/index.gsp:53

	at gsp_gscf_studyWizardindex_gsp$_run_closure2.doCall(gsp_gscf_studyWizardindex_gsp.groovy:106)

	at gsp_gscf_studyWizardindex_gsp$_run_closure2.doCall(gsp_gscf_studyWizardindex_gsp.groovy)

	at gsp_gscf_studyWizardindex_gsp.run(gsp_gscf_studyWizardindex_gsp.groovy:109)

	... 6 more

Change History

Changed 3 years ago by work@…

When in a webflow, apparently all anchors are rewritten to contain the execution parameter of the webflow. Jumping from one webflow to another then causes the second to fail as that particular execution parameter does not exist yet (e.g. ?execution=e1s1).

This is a bit of a weird bug. In order to fix this probably a Javascript should always fix the menu to remove the execution parameter...

Changed 3 years ago by work@…

  • status changed from new to closed
  • resolution set to fixed

resolved in r1840

Note: See TracTickets for help on using tickets.