Ticket #423 (closed defect: worksforme)

Opened 3 years ago

Last modified 3 years ago

in study wizard as in study overview sample order not consistent

Reported by: janneke@… Owned by: work@…
Priority: major Milestone: 0.8.2
Component: Study view Version: 0.8.0
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

When I create a study with subjects and sampling events, I get a list of my samples. However, both in the wizard step 4 (samples) as in study overview (samples) samples are not ordered by subject.
It seems that sometimes the first half is ordered by subject, whereas the second half is randomly listed.

It would be easy to verify the list if samples are shown either by parent subject, or sample name (which is also based on parent subject I guess)

Attachments

2011_2may sample order.png Download (77.8 KB) - added by janneke@… 3 years ago.

Change History

Changed 3 years ago by janneke@…

Changed 3 years ago by business@…

  • status changed from new to assigned

* add column 'sampling event start time'
* sort sample list on Sample template (as already done) Sampling Event template, Sampling event start time, sample name.

Changed 3 years ago by work@…

  • owner changed from work@… to business@…

Actually, it is not that simple to sort on multiple entities. I have now set samples to sort on subject names:

		samples.findAll { it.template.equals(template) }.sort {
			it.parentSubject.name
		}

If you have a better solution, be my guest :)

r1836

I've added the start time to the sampling event display

Changed 3 years ago by work@…

  • milestone changed from 0.8.1 to 0.8.2

leaving the issue open cause Kees still has to give feedback, but moving to 0.8.2 milestone

Changed 3 years ago by business@…

suggestion:

.sort {
 [it.parentEvent.?template, it.parentEvent.?startTime, it.parentSubject.?name]
}

Changed 3 years ago by business@…

  • owner changed from business@… to work@…

Changed 3 years ago by work@…

  • owner changed from work@… to business@…

resolved in r1857

Changed 3 years ago by business@…

  • owner changed from business@… to work@…

Does not seem to work on CI (see e.g. study Linea - 2)...

Changed 3 years ago by work@…

sorting on a concatenated string instead in r1870

Changed 3 years ago by work@…

  • owner changed from work@… to janneke@…

Changed 3 years ago by janneke@…

  • owner changed from janneke@… to work@…

Seems working now, although I have one example where the order is not intuitive

 http://ci.nmcdsp.org/gscf-0.8.1-ci/studyWizard/pages?execution=e1s1
study 001LINEA, dan in de wizard naar samples. Order in there is:

group1_2w
group2_2w
group1_3w
group2_3w
group1_4w
group2_4w
group1_1w
group2_1w

Within these groups order is following subjects, however 1w should come first.

Changed 3 years ago by work@…

  • status changed from assigned to closed
  • resolution set to worksforme

cannot reproduce, looks fine here if I look up 001Linea on ci...

Note: See TracTickets for help on using tickets.