Ticket #372 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Error when adding a field to a template on CI

Reported by: robert@… Owned by: robert@…
Priority: major Milestone: 0.7.0
Component: Unknown Version: 0.6.6
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

I tried to add a template field to a template. This resulted in the following error (apparently it has something to do with the lastUpdated field):

Could not add template field: <html><head><title>Grails Runtime Exception</title><style type="text/css">
	  		.message {
	  			border: 1px solid black;
	  			padding: 5px;
	  			background-color:#E9E9E9;
	  		}
	  		.stack {
	  			border: 1px solid black;
	  			padding: 5px;
	  			overflow:auto;
	  			height: 300px;
	  		}
	  		.snippet {
	  			padding: 5px;
	  			background-color:white;
	  			border:1px solid black;
	  			margin:3px;
	  			font-family:courier;
	  		}
	  </style></head><body>
    <h1>Grails Runtime Exception</h1>
    <h2>Error Details</h2>

  	<div class="message">
		<strong>Error 500:</strong> Executing action [addField] of controller [org.dbnp.gdt.TemplateEditorController] in plugin [gdt] caused exception: not-null property references a null or transient value: org.dbnp.gdt.Template.lastUpdated; nested exception is org.hibernate.PropertyValueException: not-null property references a null or transient value: org.dbnp.gdt.Template.lastUpdated<br>
		<strong>Servlet:</strong> grails<br>
		<strong>URI:</strong> /gscf-0.6.7-ci/grails/templateEditor/addField.dispatch<br>
		
	  		<strong>Exception Message:</strong> not-null property references a null or transient value: org.dbnp.gdt.Template.lastUpdated <br>
	  		<strong>Caused by:</strong> not-null property references a null or transient value: org.dbnp.gdt.Template.lastUpdated <br>
	  		<strong>Class:</strong> TemplateEditorController <br>
	  		<strong>At Line:</strong> [606] <br>
	  		<strong>Code Snippet:</strong><br>
	  		<div class="snippet">
	  			

Change History

Changed 3 years ago by work@…

  • status changed from new to assigned
  • milestone set to 0.7.0

known issue, DatabaseUpgrade?.groovy should be extended to check for NULL values in 'date_created' and 'last_updated' columns --> set them to now()

Changed 3 years ago by work@…

  • owner changed from work@… to robert@…

resolved in r1657

Changed 3 years ago by robert@…

  • status changed from assigned to closed
  • resolution set to fixed

Seems to be solved now. Closing the ticket

Note: See TracTickets for help on using tickets.