Ticket #367 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Subject - event group assignments disappear

Reported by: business@… Owned by: business@…
Priority: major Milestone: 0.7.1
Component: Unknown Version: 0.6.6
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

On test.dbnp.org, if I follow these steps:

1. login as 'user'
2. go to  http://test.dbnp.org/gscf-0.6.6-dbnptest/study/show/1380
3. click 'Edit'
4. go to '3. Events'
5. click 'next'
6. click 'next'
7. click 'previous'
8. click 'previous'

The subject-group assigments have changed! Which shouldn't be the case of course.

Change History

Changed 3 years ago by business@…

  • status changed from new to closed
  • resolution set to invalid

Hmm can't reproduce this problem myself now anymore. So closing the ticket. But something strange is going on with this study, there are much less samples generated than should be. Can't really continue testing until #364 is fixed.

Changed 3 years ago by business@…

After a while the problem re-appeared... after a save actually all my group assignments were gone. Not exactly funny, so we have to go over this code carefully.

Changed 3 years ago by work@…

  • status changed from closed to reopened
  • resolution invalid deleted

might have been related to #364, please retest...

Changed 3 years ago by work@…

  • status changed from reopened to assigned
  • owner changed from work@… to business@…

Changed 3 years ago by work@…

  • milestone set to 0.7.0

Changed 3 years ago by work@…

  • milestone changed from 0.7.0 to 0.7.1

Changed 3 years ago by work@…

is this closed, or is this still valid? please test on ci and not on dbnp.org...

Changed 3 years ago by business@…

  • status changed from assigned to closed
  • resolution set to fixed

Cannot reproduce anymore, closing.

Changed 3 years ago by business@…

  • status changed from closed to reopened
  • resolution fixed deleted

Changed 3 years ago by business@…

  • status changed from reopened to assigned
  • owner changed from business@… to work@…

Also, all samples are gone then.

Changed 3 years ago by work@…

  • owner changed from work@… to business@…

This is resolved in r1732

I documented this in code:

if (this.loadStudy(flow, flash, [studyid:flow.jump.id],authenticationService.getLoggedInUser())) {

// iterate through eventgroups and get their identifiers. Somehow
// we really need to do this here, otherwise (only!) the eventGroup's
// identifiers keep iterating in the events page, messing up the
// GET request, and deleting all samples
// use case: 1) load study
// 2) click samples tab
// 3) click events tab (eventGroup identifiers increases for the SAME
// eventGroup while you would expect the identifier for a eventGroup
// to remain stable)
// 4) click next or sample tab --> get parameters are wrong so all samples
// are deleted
// 5) click on the events tab --> the eventGroup identifiers are now stable?!
// The only thing that makes EventGroup? different from the other entities is that
// EventGroup? extends Identity directly, while the other entities extend TemplateEntity?
// which in turn extends Identity.
//
// The following line fixed the issue, but it is extremely weird we even have to do this...
flow.study.eventGroups.each { it.getIdentifier() }

toStudyPage()

}

Changed 3 years ago by business@…

  • status changed from assigned to closed
  • resolution set to fixed

Tested with SVN HEAD and a tunnel to test.nmcdsp.org database, seems solved.

Note: See TracTickets for help on using tickets.