Ticket #347 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

importer wizard does not check for duplicate identifiers

Reported by: business@… Owned by: s.h.sikkema@…
Priority: major Milestone: 0.7.0
Component: Import wizard Version: 0.6.5
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

When I import subjects with 'Linea subject' template on ci.nmcdsp.org and assign the same name to multiple rows, the importer goes past step 3 and ends up with an error

2011-03-07 12:00:27,497 [TP-Processor9] ERROR builder.ClosureInvokingAction  - Exception occured invoking flow action: Could not execute JDBC batch update; SQL [insert into subject (version, subjectname, species_id, template_id, parent_id, subjects_idx, id) values (?, ?, ?, ?, ?, ?, ?)]; constraint [null]; nested exception is org.hibernate.exception.ConstraintViolationException: Could not execute JDBC batch update
org.springframework.dao.DataIntegrityViolationException: Could not execute JDBC batch update; SQL [insert into subject (version, subjectname, species_id, template_id, parent_id, subjects_idx, id) values (?, ?, ?, ?, ?, ?, ?)]; constraint [null]; nested exception is org.hibernate.exception.ConstraintViolationException: Could not execute JDBC batch update
	at dbnp.importer.ImporterService.saveDatamatrix(ImporterService.groovy:377)
	at dbnp.importer.ImporterService$saveDatamatrix.call(Unknown Source)
	at dbnp.importer.ImporterController.saveEntities(ImporterController.groovy:663)
	at dbnp.importer.ImporterController$_closure2_closure20_closure35.doCall(ImporterController.groovy:267)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:774)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:896)
	at java.lang.Thread.run(Thread.java:662)
Caused by: org.hibernate.exception.ConstraintViolationException: Could not execute JDBC batch update
	... 10 more
Caused by: java.sql.BatchUpdateException: Batch entry 1 insert into subject (version, subjectname, species_id, template_id, parent_id, subjects_idx, id) values (0, y, 128, 220, 29057, 1, 29059) was aborted.  Call getNextException to see the cause.
	at org.postgresql.jdbc2.AbstractJdbc2Statement$BatchResultHandler.handleError(AbstractJdbc2Statement.java:2533)
	at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1317)
	at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:350)
	at org.postgresql.jdbc2.AbstractJdbc2Statement.executeBatch(AbstractJdbc2Statement.java:2592)
	at org.apache.commons.dbcp.DelegatingStatement.executeBatch(DelegatingStatement.java:297)
	at org.apache.commons.dbcp.DelegatingStatement.executeBatch(DelegatingStatement.java:297)
	... 10 more

Change History

Changed 3 years ago by business@…

You can check this using the file  https://trac.nbic.nl/gscf/attachment/ticket/140/subjecttest.xls.
Make a webtest out of it!

Changed 3 years ago by business@…

  • owner changed from business@… to t.w.abma@…
  • component changed from Unknown to Import wizard

Changed 3 years ago by business@…

  • status changed from new to assigned
  • version changed from 0.6.3 to 0.6.5
  • milestone set to 0.7.0

Changed 3 years ago by work@…

  • owner changed from t.w.abma@… to s.h.sikkema@…

Changed 3 years ago by s.h.sikkema@…

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.