Ticket #345 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Cloning templates has stopped working

Reported by: robert@… Owned by: robert@…
Priority: major Milestone:
Component: Unknown Version: 0.6.5
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

Cloning a template from the template editor raises an error. It seems to be caused by the fact that cloning a template needs a SecUser? from authenticationService. Also, it seems that the needed constructor for a template (public Template( Template otherTemplate, SecUser? owner ), maybe altered not to use owner anymore?) is missing since the refactoring. The original code can be found here:

 https://trac.nbic.nl/gscf/browser/trunk/grails-app/domain/dbnp/studycapturing/Template.groovy?rev=1200

Change History

Changed 3 years ago by work@…

  • status changed from new to assigned
  • owner changed from work@… to robert@…

Resolved in  GDT r192 and r1615, please retest

Changed 3 years ago by robert@…

  • status changed from assigned to closed
  • resolution set to fixed

Seems to be working again.

Note: See TracTickets for help on using tickets.