Ticket #342 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

emails can't be sent from test.dbnp.org

Reported by: robert@… Owned by: business@…
Priority: major Milestone: Must have
Component: General Version: 0.7.0
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

When registering as a new user on test.dbnp.org, a message appears 'mail could not be sent to administrators'. Also, I don't receive an email myself.

This is probably some configuration issue. Hope you can look into it

Change History

Changed 3 years ago by work@…

  • owner changed from work@… to robert@…
  • status changed from new to assigned

please retest on nbx14, this should probably be resolved...

Changed 3 years ago by work@…

  • version changed from 0.6.5 to 0.6.6

Changed 3 years ago by business@…

  • milestone set to 0.7.0

Changed 3 years ago by robert@…

  • owner changed from robert@… to work@…

E-mail works now, but the sender is '{}@dbnp.org'. Please change it to a more descriptive name.

Changed 3 years ago by work@…

  • status changed from assigned to closed
  • resolution set to wontfix

cannot fix at this stage, the issue is two fold:

1. on dbnp.org we require the local mailer (postfix, port 25)
2. on nmcdsp.org we require gmail as a mailer (port 465)

While the configuration is right (local mailer for dbnp.org, or gmail for nmcdsp.org or development) the mailer does NOT use the proper configuration but defaults to port 25.

Which means the mail plugin itself is broken or does not respect configuration.

This should be properly fix in a configuration wizard (see #185)

Changed 3 years ago by robert@…

  • status changed from closed to reopened
  • resolution wontfix deleted

Not fixed yet, and can be fixed now.

Changed 3 years ago by work@…

  • owner changed from work@… to robert@…
  • status changed from reopened to assigned
  • milestone changed from 0.7.0 to 0.7.1

gmail is gone in r1669, removed it from the servers as well... still no mail... what is the administrator's email where it is al sent to? It all looks like a black hole to me...

Robert, your're the author of the authentication logic, perhaps you know where it all goes...

Also it would have been nice if the code was documented...

Changed 3 years ago by robert@…

  • owner changed from robert@… to work@…

administrator mails are sent to the administrator users (admin@… on ci). I've added a default sender to the configuration. I suppose it will work now on test.dbnp.org.

Since you've deleted the gmail stuff, please add an alternative for testing.

Changed 3 years ago by work@…

  • owner changed from work@… to business@…

reassigning to Kees to assign to prioritize as I will not be able to pick this up before tuesday and the deadline is wednesday...

Changed 3 years ago by business@…

  • version changed from 0.6.6 to 0.7.0
  • milestone changed from 0.7.1 to Must have

OK, sending emails seems to work on CI, so probably will work too when deployed on test.dbnp.org.
So this issue is now about putting the gmail settings back in development mode for testing purposes. Have to discuss with Jeroen what the reason was for removing that (security?)

Changed 3 years ago by work@…

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.