Ticket #312 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Template editor opens without layout when opened from menu

Reported by: robert@… Owned by: robert@…
Priority: major Milestone: 0.6.5
Component: Unknown Version: 0.6.3
Keywords: Cc: work@…
Hardware: Operating system:
Product: URL:


When opening the template editor from the menu, the layout disappears. This probably has to do with #225

Change History

comment:1 Changed 5 years ago by business@…

  • Status changed from new to assigned
  • Owner changed from business@… to robert@…
  • Cc work@… added
  • Milestone set to 0.6.4

According to Jeroen, this might be caused by the after interceptor not functioning properly (do you have to change the view earlier?)

comment:2 Changed 5 years ago by work@…

The layout is dynamically changed in the model by an afterInterceptor in the TemplateEditorController. While the code seems straightforward, it results in unexpected behaviour:


  • Fires after every action and determines the layout of the page */

def afterInterceptor = { model, modelAndView ->

if (paramsstandalone? && paramsstandalone? == 'true') {

model.layout = 'main';
model.extraparams = ['standalone': 'true'];

} else {

model.layout = 'dialog';
model.extraparams = [];



comment:3 Changed 5 years ago by robert@…

  • Owner changed from robert@… to work@…

This has worked before perfectly (before the refactoring) and also works fine with the contacts. Please check what has changed during refactoring

comment:4 Changed 5 years ago by work@…

  • Owner changed from work@… to robert@…

Fixed in gdt 0.0.17 (GDT revision r172)

comment:5 Changed 5 years ago by work@…

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.