Ticket #296 (closed enhancement: duplicate)

Opened 3 years ago

Last modified 3 years ago

Nice to have: on duplicate identifiers, generate a unique identifier name and mark fields red + warning

Reported by: work@… Owned by: t.w.abma@…
Priority: major Milestone: 0.6.6
Component: Import wizard Version: 0.6.3
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

Currently, when you import a subject sheets which contains names (=identifiers) which already exist, you get a unique error and you need to fix the names.

It would be nice if there would be an option to:
- automatically make the identifier field unique (in grails --> contatenate + 1 as long as the name unique)
- or update original?

Change History

Changed 3 years ago by business@…

If a name already exists in the database, the existing record should be updated. But do notify the user of that!

For double identifiers, the current error message can be retained (identifier that occurs multiple times doesn't make sense).

Changed 3 years ago by business@…

  • status changed from new to assigned
  • milestone changed from Should have to 0.6.6

Changed 3 years ago by business@…

  • status changed from assigned to closed
  • resolution set to duplicate

Duplicate of #249

Note: See TracTickets for help on using tickets.