Ticket #287 (closed defect: worksforme)

Opened 3 years ago

Last modified 3 years ago

Exception when adding a term that already exists in the term editor

Reported by: business@… Owned by: work@…
Priority: major Milestone: Should have
Component: GDT Version: 0.6.3
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description (last modified by business@…) (diff)

On demo.dbnp.org, if I add a term to an ontology field (tested: species ontology) which already exists in the database, I get an error:

Grails Runtime Exception
Error Details
Error 500: Exception thrown executing org.codehaus.groovy.grails.webflow.engine.builder.ClosureInvokingAction@12b7fe6 in state 'terms' of flow 'termEditor/pages' -- action execution attributes were 'map[[empty]]'
Servlet: grails
URI: /gscf-0.6.4-dbnpdemo/grails/termEditor/pages.dispatch
Exception Message: Cannot cast object '[Cannot cast object '['Solanum lycopersicum' already exists, either search for another term or close this window]' with class 'java.util.ArrayList' to class 'org.springframework.validation.Errors' due to: groovy.lang.GroovyRuntimeException: Could not find matching constructor for: org.springframework.validation.Errors(java.lang.String)]' with class 'java.util.ArrayList' to class 'org.springframework.validation.Errors' due to: groovy.lang.GroovyRuntimeException: Could not find matching constructor for: org.springframework.validation.Errors(org.codehaus.groovy.runtime.GStringImpl)
Caused by: Exception thrown executing org.codehaus.groovy.grails.webflow.engine.builder.ClosureInvokingAction@12b7fe6 in state 'terms' of flow 'termEditor/pages' -- action execution attributes were 'map[[empty]]'
Class: TermEditorController
At Line: [122]
Code Snippet:
Stack Trace

org.springframework.webflow.execution.ActionExecutionException: Exception thrown executing org.codehaus.groovy.grails.webflow.engine.builder.ClosureInvokingAction@12b7fe6 in state 'terms' of flow 'termEditor/pages' -- action execution attributes were 'map[[empty]]'

	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)

	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)

	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:774)

	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)

	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:896)

	at java.lang.Thread.run(Thread.java:662)

Caused by: org.codehaus.groovy.runtime.typehandling.GroovyCastException: Cannot cast object '[Cannot cast object '['Solanum lycopersicum' already exists, either search for another term or close this window]' with class 'java.util.ArrayList' to class 'org.springframework.validation.Errors' due to: groovy.lang.GroovyRuntimeException: Could not find matching constructor for: org.springframework.validation.Errors(java.lang.String)]' with class 'java.util.ArrayList' to class 'org.springframework.validation.Errors' due to: groovy.lang.GroovyRuntimeException: Could not find matching constructor for: org.springframework.validation.Errors(org.codehaus.groovy.runtime.GStringImpl)

	at dbnp.studycapturing.TermEditorController$_closure2_closure4_closure7.doCall(TermEditorController.groovy:122)

	... 6 more

Change History

Changed 3 years ago by business@…

  • description modified (diff)

Changed 3 years ago by work@…

  • owner changed from business@… to work@…
  • status changed from new to assigned
  • component changed from Unknown to GDT

Changed 3 years ago by work@…

  • status changed from assigned to accepted

Changed 3 years ago by work@…

  • status changed from accepted to closed
  • resolution set to worksforme

Cannot reproduce with svn HEAD (revision 1458), PostgreSQL forward to dnpdemo database and using the termEditor:  http://localhost:8080/gscf/termEditor?ontologies=1132

Closing issue...

Note: See TracTickets for help on using tickets.