Ticket #269 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

description is string not text

Reported by: jildau.bouwman@… Owned by: business@…
Priority: major Milestone: 0.6.2
Component: Study create/edit wizard Version:
Keywords: Cc:
Product: Operating system: Windows XP
URL: Hardware:

Description

You will get an exception if the description field contains more then 255 chars. According to the template editor this field should be a text field, but it is a string.

Change History

Changed 3 years ago by work@…

2011-01-11 17:07:57,949 [TP-Processor12] ERROR util.JDBCExceptionReporter - Batch entry 0 insert into study (version, code, date_created, description, last_updated, owner_id, publicstudy, published, start_date, template_id, title, id) values (0, 6374, 2011-01-11 17:07:57.827000 +0100, To study the metabolic changes induced by a mild anti-inflammatory drug intervention (diclofenac), plasma metabolic profiling was applied in overweight human volunteers with elevated levels of the inflammatory plasma marker C-reactive protein. Liquid and gas chromatography mass spectrometric methods were used to detect high and low abundant plasma metabolites both in fasted conditions and during an oral glucose tolerance test. The study was designed as a double blind, randomized, parallel trial, in which subjects were treated with diclofenac (n=10) or placebo (n=10). , 2011-01-11 17:07:57.827000 +0100, 2, 0, 0, 2005-06-20 00:00:00.000000 +0200, 1786, Relation between reduction of the inflammatory status and glucose metabolism in healthy overweight men , 1791) was aborted. Call getNextException to see the cause.
2011-01-11 17:07:57,972 [TP-Processor12] ERROR util.JDBCExceptionReporter - ERROR: value too long for type character varying(255)
2011-01-11 17:07:57,974 [TP-Processor12] ERROR events.PatchedDefaultFlushEventListener? - Could not synchronize database state with session
org.hibernate.exception.DataException?: Could not execute JDBC batch updat

This was partly fixed in r1327, however while the code _was_ fixed, the database wasn't. For such a change the UpgradeDatabase?.groovy should be updated so an automated database change is performed if necessary...

Changed 3 years ago by work@…

  • status changed from new to closed
  • resolution set to fixed

resolved in r1365, assigning to Kees for code review

Changed 3 years ago by work@…

  • status changed from closed to reopened
  • resolution fixed deleted

Changed 3 years ago by work@…

  • status changed from reopened to assigned
  • owner changed from work@… to business@…

Changed 3 years ago by work@…

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.