Ticket #265 (closed enhancement: fixed)

Opened 3 years ago

Last modified 3 years ago

A new user cannot import new studies via importer

Reported by: business@… Owned by: business@…
Priority: minor Milestone: Should have
Component: Import wizard Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

If you create a new user (e.g. via login as admin and then create user) there are no studies yet in the database. This means that if you log in as that user and go directly to Import studies) and then e.g. follow ScenarioEugene, you get an empty study dropdown and an error when you click next:

2011-01-11 12:01:07,413 [TP-Processor16] ERROR errors.GrailsExceptionResolver  - Exception occurred when processing request: [POST] /gscf-0.6.1-ci/importer/pages - parameters:
_eventId_next: 1
sheetindex: 1
entity: 5HsD3xAJxbF2CqLfSBgwZeFle3dJ9AdkBPs7son%2F%2FhI%3D
template_id: 1025
headerrow: 1
importfile: NTC_Experiment_test3.xls
datamatrix_start: 2
execution: e2s2
execution: e2s1
Stacktrace follows:
org.springframework.webflow.execution.ActionExecutionException: Exception thrown executing org.codehaus.groovy.grails.webflow.engine.builder.ClosureInvokingAction@456ecd1b in state 'pageOne' of flow 'importer/pages' -- action execution attributes were 'map[[empty]]'
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:774)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:896)
	at java.lang.Thread.run(Thread.java:662)
Caused by: java.lang.NullPointerException: Cannot get property 'id' on null object
	at dbnp.importer.ImporterController.fileImportPage(ImporterController.groovy:345)
	at dbnp.importer.ImporterController$_closure2_closure10_closure19.doCall(ImporterController.groovy:123)
	... 6 more
2011-01-11 12:01:07,418 [TP-Processor16] ERROR servlet.GrailsDispatcherServlet  - HandlerInterceptor.afterCompletion threw exception
java.lang.NullPointerException
	at BaseFilters$_closure1_closure3_closure7.doCall(BaseFilters.groovy:42)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:774)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:896)
	at java.lang.Thread.run(Thread.java:662)


Change History

Changed 3 years ago by t.w.abma@…

  • owner changed from t.w.abma@… to business@…
  • status changed from new to assigned

Added exception for when importing a new study, it doesn't use the non-existent study identifier anymore. Works here on CI now.

Changed 3 years ago by business@…

  • priority changed from blocker to minor
  • type changed from defect to enhancement
  • milestone changed from 0.6.2 to 0.7

It would also be nice (more logical) if the entity and study dropdowns were swapped, so that if you choose Study first the choice for a study disappears in stead of the other way around.

Changed 3 years ago by work@…

  • component changed from Unknown to Import wizard

Changed 3 years ago by business@…

  • owner changed from business@… to t.w.abma@…

Changed 3 years ago by t.w.abma@…

  • owner changed from t.w.abma@… to business@…

Swapped study and entity dropdown selectors in revision 1500.

Changed 3 years ago by business@…

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.