Ticket #251 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

I cannot store a new study on test.dbnp.org

Reported by: jildau.bouwman@… Owned by: business@…
Priority: major Milestone:
Component: Unknown Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

On test.dbnp.org quicksave leads to:

error:
exception → org.springframework.dao.DataIntegrityViolationException?: Could not execute JDBC batch update; SQL [insert into study (version, code, date_created, description, last_updated, owner_id, publicstudy, published, start_date, template_id, title, id) values (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)]; nested exception is org.hibernate.exception.DataException?: Could not execute JDBC batch update, see log for stacktrace

Change History

Changed 3 years ago by business@…

  • status changed from new to closed
  • resolution set to fixed

I found the stack trace.
This was caused by [1245]. The description field was moved to the domain fields, but the TEXT claused was not re-added.
Fixed by [1327]. This is fixed now also on test.dbnp.org, however keep an eye on #254, the bad news is that you might not be able to edit studies... Working on this.

2010-12-30 08:46:21,840 [TP-Processor9] ERROR util.JDBCExceptionReporter  - Batch entry 0 insert into study (version, code, date_created, description, last_updated, owner_id, publicstudy, published, start_date, template_id, title, id) values (0, 6374, 2010-12-30 08:46:21.786000 +0100, To study the metabolic changes induced by a mild anti-inflammatory drug intervention (diclofenac), plasma metabolic profiling was applied in overweight human volunteers with elevated levels of the inflammatory plasma marker C-reactive protein. Liquid and gas chromatography mass spectrometric methods were used to detect high and low abundant plasma metabolites both in fasted conditions and during an oral glucose tolerance test. The study was designed as a double blind, randomized, parallel trial, in which subjects were treated with diclofenac (n=10) or placebo (n=10)., 2010-12-30 08:46:21.786000 +0100, 2, 0, 0, 2005-06-20 00:00:00.000000 +0200, 7, Relation between reduction of the inflammatory status and glucose metabolism in healthy overweight men code 	6374, 326) was aborted.  Call getNextException to see the cause.
2010-12-30 08:46:21,841 [TP-Processor9] ERROR util.JDBCExceptionReporter  - ERROR: value too long for type character varying(255)

etc.

Note: See TracTickets for help on using tickets.