Ticket #244 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Importer error after first step

Reported by: business@… Owned by: business@…
Priority: major Milestone: 0.6.2
Component: Unknown Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

After trying to import a sample sheet:

2010-12-21 12:08:17,675 [TP-Processor5] ERROR errors.GrailsExceptionResolver? - Exception occurred when processing request: [POST] /gscf-0.6.1-ci/importer/pages - parameters:
_eventId_next: 1
study.id: 1470
sheetindex: 1
entity: Hio/Hbxswv?8ldnk119F0gTsfMYnWsnQv31L4D4Bx4Qo=
template_id: 59
headerrow: 1
execution: e1s2
execution: e1s1
importfile: Linea_SampleList_AllBatches1.xlsx
datamatrix_start: 2
Stacktrace follows:
org.springframework.webflow.execution.ActionExecutionException?: Exception thrown executing org.codehaus.groovy.grails.webflow.engine.builder.ClosureInvokingAction?@2f269032 in state 'pageOne' of flow 'importer/pages' -- action execution attributes were 'map

Error: Failed to load processor empty
No macro or processor named 'empty' found

'

at org.apache.jk.server.JkCoyoteHandler?.invoke(JkCoyoteHandler?.java:190)
at org.apache.jk.common.HandlerRequest?.invoke(HandlerRequest?.java:291)
at org.apache.jk.common.ChannelSocket?.invoke(ChannelSocket?.java:774)
at org.apache.jk.common.ChannelSocket?.processConnection(ChannelSocket?.java:703)
at org.apache.jk.common.ChannelSocket?$SocketConnection?.runIt(ChannelSocket?.java:896)
at java.lang.Thread.run(Thread.java:619)

Caused by: org.codehaus.groovy.runtime.typehandling.GroovyCastException?: Cannot cast object '1.0' with class 'org.apache.poi.xssf.usermodel.XSSFCell' to class 'org.apache.poi.hssf.usermodel.HSSFCell'

at dbnp.importer.ImporterService?.getDatamatrix(ImporterService?.groovy:174)
at dbnp.importer.ImporterService?$$FastClassByCGLIB$$3550d3b5.invoke(<generated>)
at net.sf.cglib.proxy.MethodProxy?.invoke(MethodProxy?.java:149)
at dbnp.importer.ImporterService?$$EnhancerByCGLIB$$9e9f5310.getDatamatrix(<generated>)
at dbnp.importer.ImporterService?$getDatamatrix.call(Unknown Source)
at dbnp.importer.ImporterController?.fileImportPage(ImporterController?.groovy:365)
at dbnp.importer.ImporterController?$_closure2_closure10_closure19.doCall(ImporterController?.groovy:121)
... 6 more

Change History

Changed 3 years ago by t.w.abma@…

  • owner changed from t.w.abma@… to business@…
  • status changed from new to assigned

Seems that the (latest?) POI-library returns a XSSFCell-object when trying to retrieve a cell, instead of an HSSFCell-object, didn't see this one before. Works fine here now.

Changed 3 years ago by t.w.abma@…

Found the cause, it depends on the type of Excel file used (newer Excel-versions return XSSFCell instead of HSSFCell).

Changed 3 years ago by work@…

  • status changed from assigned to closed
  • resolution set to fixed

from the text above I assume this is resolved... closing the issue

Note: See TracTickets for help on using tickets.