Ticket #242 (closed defect: wontfix)

Opened 3 years ago

Last modified 3 years ago

Incorrect error when not adding a sampling event

Reported by: robert@… Owned by: work@…
Priority: minor Milestone:
Component: Study create/edit wizard Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

When creating a study, an error appears when no events are created:

"In the previous page one (or more) sampling events were not assigned to a group which means no samples will be generated for these sampling events. If this is in error, please go back to the previous page and make sure to properly group the sampling events. If, however, this is how you intended it, press next to continue, or wait 11seconds... "

However, this error should probably be rephrased, since the first sentence can't be true (I don't have any events).

The error is also shown when I have created a non-sampling event, and assigned it to a group.

Change History

  Changed 3 years ago by work@…

  • status changed from new to assigned
  • owner changed from work@… to robert@…

resolved in r1285, please test

  Changed 3 years ago by robert@…

  • owner changed from robert@… to work@…

Great. I see a correct message now, but it is in Dutch:"

"In de voorgaande pagina zijn een of meer sampling events niet toegekend aan een groep. Dat houdt in dat voor deze sampling events geen samples zullen worden gegenereerd. Als dit niet juist is, ga dan terug naar de vorige pagina en zorg ervoor dat alle sampling events correct worden gegroepeerd. Als het echter expres zo is ingevoerd, klik dan op volgende om verder te gaan, of wacht 10seconden... "

I'm not really sure why it is in Dutch, since the rest of the application is in English.

I've noticed similar errors in the person list view (it says "Person Aanmaken"). Probably it has something to do with i18n.

follow-up: ↓ 4   Changed 3 years ago by work@…

  • status changed from assigned to closed
  • resolution set to wontfix

True, but that is by design as the error has been added to the Dutch i18n files as well... The issue you should have raised is that the rest of the site is not in English ;)

This means we should:
1. decide of the whole application should be UK English only
2. translate other things into Dutch as well...

I think we should move everything into the i18n files so we can support multiple languages in the future...

For now, I'll close this issue...

in reply to: ↑ 3   Changed 3 years ago by work@…

Of course I meant: "the rest of the site is not in English" :)

Note: See TracTickets for help on using tickets.