Ticket #233 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

"NTC Study" template on CI instance contains required fields that are not enforced

Reported by: work@… Owned by: business@…
Priority: major Milestone: 0.6.2
Component: General Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

These fields are marked properly with the arrow in the study page of the wizard. However, when you leave them blank and continue to the next page it is allowed. Seems like the validation method is not properly validating the required part of template fields.

For example see 'GSE5509' study on CI instance...

Change History

Changed 3 years ago by work@…

This is caused by a design flaw in TemplateEntity?.groovy. The custom validators work perfectly fine, however, when a template field is not set it does not exist in it's respective internal map so it cannot be validated.

The validation method should be extended to also check if required fields are properly set

Changed 3 years ago by work@…

  • owner changed from work@… to business@…
  • status changed from new to assigned

Resolved in r1264, validation of an object which inherits from TemplateEntity? did not result in an error when required templateFields were missing.

Assigning to Kees for confirmation / code review

Changed 3 years ago by business@…

  • status changed from assigned to closed
  • resolution set to fixed

Works fine as far as I have tested it! The code has a lot of duplication, but that would be hard to solve as we saw before.

Note: See TracTickets for help on using tickets.