Ticket #232 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

facebook link breaks menu in IE7

Reported by: robert@… Owned by: robert@…
Priority: minor Milestone: Should have
Component: General Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

If I open a menu in IE7 (e.g. Studies), I can only select the topmost 2 items. If my mouse reaches the facebook link, the menu closes. This way, I can't reach the other menu items

Attachments

frontpage.JPG Download (111.0 KB) - added by robert@… 3 years ago.
view_studies.jpg Download (142.8 KB) - added by robert@… 3 years ago.

Change History

  Changed 3 years ago by work@…

  • owner set to robert@…
  • status changed from new to assigned

Hi Robert,

I can not debug this as I don't have Windows, let alone IE7... I'm also not sure I understand your issue... 'topmost 2 items', 'menu closes' etc... We have a horizontal menu, and the facebook link is on the bottom of the page?

Assigning back to you

  Changed 3 years ago by work@…

Tried to reproduce on Tjeerd's Laptop running Windows 7 / IE8... cannot reproduce... must be an IE7 thing?

  Changed 3 years ago by work@…

  • priority changed from blocker to minor

lowering priority...

  Changed 3 years ago by robert@…

  • owner changed from robert@… to work@…

I do think this is a IE7 problem indeed. See screenshot for clarification. When I open a menu, the facebook div seems to be on top of it (as are the tabs when viewing a study, see second screenshot). When I try to access the third or fourth menu item, my mouse has to pass the facebook-div. At that moment, the menu disappears, so I can't access my menu items.

This is an important issue as long as there is no text on the first page and the facebook buttons are in place (I've probably missed the reason why a facebook button should present).

However, there is a sort of simulate IE7 button in IE8 (press F12, the developer tools-window opens and then you can select 'simulate IE7' (or something like that) in a dropdown menu on top of that window)).

Anyway, my solution would be to remove the facebook stuff, but maybe there is a reason for those buttons.

Changed 3 years ago by robert@…

Changed 3 years ago by robert@…

  Changed 3 years ago by work@…

unfortunately I don't have windows so I cannot fix this... however, it's possible to change the z-index of the facebook links. Perhaps that will fix the issue for IE7?

  Changed 3 years ago by work@…

ps. your solution is the wrong way round, I suggest we remove IE7, but maybe there is a reason for that browser

follow-up: ↓ 8   Changed 3 years ago by work@…

  • owner changed from work@… to robert@…

Changed z-index-es in r1264, can you retest robert?

in reply to: ↑ 7   Changed 3 years ago by work@…

euhm... I ment r1265

  Changed 3 years ago by work@…

  • milestone set to 0.7

  Changed 3 years ago by robert@…

  • status changed from assigned to closed
  • resolution set to fixed

Fixed in r1266 by improving the z-index values of different elements.

Note: See TracTickets for help on using tickets.