Ticket #231 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

timeline doesn't appear after visiting other tabs

Reported by: robert@… Owned by: robert@…
Priority: major Milestone: 0.6.2
Component: Study view Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

The timeline in a study overview doesn't show after you've clicked on another tab. For example  http://ci.gscf.nmcdsp.org/gscf-0.6.0-ci/study/show/1256. Go to the events timeline tab, the timeline shows up. Go to the events table tab and back to the events timeline tab again. The timeline doesn't show. Also after going back and forth, the timeline never shows up again

Change History

Changed 3 years ago by work@…

  • owner set to robert@…
  • status changed from new to assigned
  • milestone set to 0.6.2

Cannot reproduce... must be your specific setup?

Also, might this be related to the fact that you rewrite this to AJAX and you did not re-initialize DOM handlers after an AJAX call?

Changed 3 years ago by robert@…

  • status changed from assigned to closed
  • resolution set to fixed

Solved in r1266. The timeline is now loaded when opening the show-study page, instead of using an ajax call. It shouldn't have been a problem, but resolving the IE-bug takes a lot more time than working around the problem this way.

Moreover, the events-timeline tab is a very small tab, showing only two divs and a title. The divs are filled using javascript, which is still only called when opening the tab.

Note: See TracTickets for help on using tickets.