Ticket #21 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

adding a contact without selecting a role seems possible, but results in an error

Reported by: kees.vanbochove@… Owned by: robert@…
Priority: major Milestone: 0.6
Component: Study create/edit wizard Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

If you add a study contact in the study create or edit wizard without selecting a role and then click add, an error is thrown (see below). When you delete the contact the wizard works again.
Solution: check if a role was chosen when 'Add' is clicked.

2010-06-18 14:41:15,644 [http-8080-4] ERROR builder.ClosureInvokingAction? - Exception occured invoking flow action: 1
java.lang.ArrayIndexOutOfBoundsException?: 1

at dbnp.studycapturing.WizardController?$_handleContacts_closure13.doCall(WizardController?.groovy:977)
at dbnp.studycapturing.WizardController?.handleContacts(WizardController?.groovy:975)
at dbnp.studycapturing.WizardController?$handleContacts.callCurrent(Unknown Source)
at dbnp.studycapturing.WizardController?.handleStudy(WizardController?.groovy:898)
at dbnp.studycapturing.WizardController?$_closure2_closure32_closure54.doCall(WizardController?.groovy:240)
at org.apache.shiro.web.servlet.ShiroFilter?.executeChain(ShiroFilter?.java:687)
at org.apache.shiro.web.servlet.ShiroFilter?.doFilterInternal(ShiroFilter?.java:616)
at org.apache.shiro.web.servlet.OncePerRequestFilter?.doFilter(OncePerRequestFilter?.java:81)
at java.lang.Thread.run(Thread.java:619)

2010-06-18 14:41:15,647 [http-8080-4] ERROR errors.GrailsExceptionResolver? - Exception thrown executing org.codehaus.groovy.grails.webflow.engine.builder.ClosureInvokingAction@19?2f6c3 in state 'study' of flow 'wizard/pages' -- action execution attributes were 'map[[empty]]'
org.springframework.webflow.execution.ActionExecutionException?: Exception thrown executing org.codehaus.groovy.grails.webflow.engine.builder.ClosureInvokingAction@19?2f6c3 in state 'study' of flow 'wizard/pages' -- action execution attributes were 'map[[empty]]'

at org.apache.shiro.web.servlet.ShiroFilter?.executeChain(ShiroFilter?.java:687)
at org.apache.shiro.web.servlet.ShiroFilter?.doFilterInternal(ShiroFilter?.java:616)
at org.apache.shiro.web.servlet.OncePerRequestFilter?.doFilter(OncePerRequestFilter?.java:81)
at java.lang.Thread.run(Thread.java:619)

Caused by: java.lang.ArrayIndexOutOfBoundsException?: 1

at dbnp.studycapturing.WizardController?$_handleContacts_closure13.doCall(WizardController?.groovy:977)
at dbnp.studycapturing.WizardController?.handleContacts(WizardController?.groovy:975)
at dbnp.studycapturing.WizardController?$handleContacts.callCurrent(Unknown Source)
at dbnp.studycapturing.WizardController?.handleStudy(WizardController?.groovy:898)
at dbnp.studycapturing.WizardController?$_closure2_closure32_closure54.doCall(WizardController?.groovy:240)
... 4 more

2010-06-18 14:41:15,659 [http-8080-4] ERROR [Tomcat].[localhost] - Exception Processing ErrorPage?[errorCode=500, location=/grails-errorhandler]
java.lang.IllegalStateException?: Cannot reset buffer after response has been committed

at org.apache.catalina.connector.Response.resetBuffer(Response.java:691)
at org.apache.catalina.core.StandardHostValve?.custom(StandardHostValve?.java:409)
at org.apache.catalina.core.StandardHostValve?.status(StandardHostValve?.java:343)
at org.apache.catalina.core.StandardHostValve?.throwable(StandardHostValve?.java:287)
at org.apache.catalina.core.StandardHostValve?.invoke(StandardHostValve?.java:142)
at org.apache.catalina.valves.ErrorReportValve?.invoke(ErrorReportValve?.java:102)
at org.apache.catalina.core.StandardEngineValve?.invoke(StandardEngineValve?.java:109)
at org.apache.catalina.connector.CoyoteAdapter?.service(CoyoteAdapter?.java:293)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
at java.lang.Thread.run(Thread.java:619)

Change History

Changed 4 years ago by business@…

  • status changed from new to assigned
  • owner set to robert@…
  • component set to Export functionality
  • milestone set to 0.6

Changed 4 years ago by business@…

  • component changed from Export functionality to Study create/edit wizard

Changed 3 years ago by robert@…

  • status changed from assigned to closed
  • resolution set to fixed

The script now checks whether a person and a role have been selected before adding the person/role to the study. This prevents the given error.

Note: See TracTickets for help on using tickets.