Ticket #206 (closed defect: wontfix)

Opened 3 years ago

Last modified 3 years ago

Create Study fails when using non-standard Assay

Reported by: e.vansomeren@… Owned by: work@…
Priority: major Milestone: 0.6.2
Component: General Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

I've created an Assay Template called Microarray (and Microarray2). However when I select it in the drop-down box during study creation wizard, the necessary fields are not updated.

Clicking on clinical chemistry assay or metabolomics assay (the standard options) the field to be filled in change accordingly. When selecting a newly generated template no change in fields occurs.

Change History

Changed 3 years ago by work@…

  • owner set to work@…
  • status changed from new to assigned
  • milestone set to 0.6.2

Changed 3 years ago by work@…

  • owner changed from work@… to e.vansomeren@…

Eugene, can you please provide steps to reproduce this issue?

Thanks,

Jeroen

Changed 3 years ago by e.vansomeren@…

  • owner changed from e.vansomeren@… to work@…

Login as user "user".
Go to study Gse5509_2 and edit it.

Go through all steps untill step 5.
Try to add a new assay by changing the choice in the template drop-down box.
If you select "Clinical Chemistry Assay" or "Metabolomics Assay" or "Microarray (Affymetrix)" the fields below the drop-down box change accordingly, but not when you select Microarray (should have many fields, check template) or Microarray 2. Then nothing happens with the fields below.

Changed 3 years ago by business@…

Robert says: maybe it it caused by Stringlists in these template that have a 'null' string to choose from. Have a look at template editor?

Changed 3 years ago by e.vansomeren@…

Are you succesfull in creating your own (very simple) assay template and selecting it?

Changed 3 years ago by work@…

Actually, GSE5509_2 is broken since issue #233 was fixed. It is very possible this issue was also caused by issue #233. Can you reproduce this issue in a 'clean' study?

Changed 3 years ago by work@…

Tried to reproduce using GSE5509 (as I fixed that study when resolving #233). It turns out selecting the "MicroArray? 2" assay results in the following error:

Caused by: org.codehaus.groovy.grails.web.taglib.exceptions.GrailsTagException?: Error executing tag <wizard:templateElements>: Cannot invoke method isInstance() on null object at /Users/jeroen/Workspace/grails/gscf/grails-app/views/wizard/pages/_assays.gsp:31

at Users_jeroen_Workspace_grails_gscf_grails_app_views_wizard_pagesassays_gsp$_run_closure1.doCall(_assays.gsp:41)
at Users_jeroen_Workspace_grails_gscf_grails_app_views_wizard_pages
assays_gsp$_run_closure1.doCall(_assays.gsp)

More specificaly, it breaks in:
.rendering [select] with name [platformtype] and value [-]
[description:PlatformType, name:platformtype, from:[null, Affymetrix, UPLS, GCMS, Orbitrap, LCMS nominal mass, LCMS accurate mass, Incyte, Illumina], value:null, required:false]

It seems like one of this STRINGLIST fields is 'null', just like Robert said. It seems like the template editor sometimes stores 'null'?

Editting the template only shows the following values in the STRINGLIST:

Affymetrix
UPLS
GCMS
Orbitrap
LCMS nominal mass
LCMS accurate mass
Incyte
Illumina

After editting the MicroArray? template's Platform field, the fields seem okay:

STRINGLIST:
PlatformType?
[Affymetrix, UPLS, GCMS, Orbitrap, LCMS nominal mass, LCMS accurate mass, Incyte, Illumina]

But now the 'label' field was causing a similar issue:

STRINGLIST:
Label
[null, Cy3, Cy5, biotin]

However, I can't get rid of the 'null' value by editting the template's 'label' field...

Changed 3 years ago by work@…

Microarray Template Query:
SELECT b.fields_idx,b.template_field_id,c.* FROM template_template_field b LEFT JOIN template_field c ON (c.id=b.template_field_id) WHERE b.template_fields_id=(SELECT id FROM template WHERE entity='dbnp.studycapturing.Assay' AND name='Microarray') ORDER BY fields_idx ASC

Microarray template 'label' field:
SELECT * FROM template_field_list_item WHERE parent_id=658 ORDER BY list_entries_idx ASC

Returns 3 items (Cy3, biotin and Cy5) which is as expected.

After 'reloading' the study, the label field's values are now as expected as well...

Changed 3 years ago by work@…

  • status changed from assigned to closed
  • resolution set to wontfix

Apparently, somehow the template editor inserted a 'null' field for some of the template fields. This seems to have been resolved at some point in time, as editting a STRINGLIST template field in a template which is not working properly actually fixes that broken field.

Closing this issue to 'wontfix', as while the templates on the CI instance sometimes seem to contain a 'null' value for certain fields, there does not seem to an issue (anymore) in the template editor causing this issue...

Eugene, if you -for some reason- encounter this issue again, then edit that template, open all STRINGLIST fields and 'save' them again.

If you, however encounter it again in a newly created template, please re-open this issue...

- Jeroen

Changed 3 years ago by e.vansomeren@…

OK, thanks!

Note: See TracTickets for help on using tickets.