Ticket #200 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Error met import van Samples in DCL template

Reported by: m.s.vanvliet@… Owned by: m.s.vanvliet@…
Priority: critical Milestone: 0.6.2
Component: Import wizard Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

2010-11-18 09:42:34,978 [http-8080-1] ERROR errors.GrailsExceptionResolver? - No such property: INTEGER for class: dbnp.studycapturing.TemplateFieldType?
groovy.lang.MissingPropertyException?: No such property: INTEGER for class: dbnp.studycapturing.TemplateFieldType?

at dbnp.importer.ImporterService?$_getHeader_closure2.doCall(ImporterService?.groovy:91)
at dbnp.importer.ImporterService?.getHeader(ImporterService?.groovy:57)
at dbnp.importer.ImporterService?$$FastClassByCGLIB$$3550d3b5.invoke(<generated>)
at net.sf.cglib.proxy.MethodProxy?.invoke(MethodProxy?.java:149)
at dbnp.importer.ImporterService?$$EnhancerByCGLIB$$c47dd104.getHeader(<generated>)
at dbnp.importer.ImporterService?$getHeader.call(Unknown Source)
at dbnp.importer.ImporterController?$_closure5.doCall(ImporterController?.groovy:98)
at dbnp.importer.ImporterController?$_closure5.doCall(ImporterController?.groovy)
at java.lang.Thread.run(Thread.java:619)

Change History

Changed 3 years ago by t.w.abma@…

  • owner changed from t.w.abma@… to m.s.vanvliet@…
  • status changed from new to assigned

In revision 1164, removed INTEGER/FLOAT template field type support and replaced it with LONG/DOUBLE. Importer works here again.

Changed 3 years ago by m.s.vanvliet@…

  • owner changed from m.s.vanvliet@… to t.w.abma@…

The previous error was fixed. But now after validating the import I get this:

(I did notice it wanted to import 3 empty rows from the Excel, which I could not remove in the validation step)

Grails Runtime Exception

Error Details

Error 500: Executing action [savePostview] of controller [dbnp.importer.ImporterController?] caused exception: object references an unsaved transient instance - save the transient instance before flushing: dbnp.studycapturing.Sample; nested exception is org.hibernate.TransientObjectException?: object references an unsaved transient instance - save the transient instance before flushing: dbnp.studycapturing.Sample
Servlet: grails
URI: /gscf/grails/importer/savePostview.dispatch
Exception Message: object references an unsaved transient instance - save the transient instance before flushing: dbnp.studycapturing.Sample
Caused by: object references an unsaved transient instance - save the transient instance before flushing: dbnp.studycapturing.Sample
Class: ImporterController?
At Line: [320]
Code Snippet:
Stack Trace

org.hibernate.TransientObjectException?: object references an unsaved transient instance - save the transient instance before flushing: dbnp.studycapturing.Sample

at dbnp.importer.ImporterService?$$EnhancerByCGLIB$$11429aae.saveDatamatrix(<generated>)

at dbnp.importer.ImporterService?$saveDatamatrix.call(Unknown Source)

at dbnp.importer.ImporterController?$_closure10.doCall(ImporterController?.groovy:320)

at dbnp.importer.ImporterController?$_closure10.doCall(ImporterController?.groovy)

at java.lang.Thread.run(Thread.java:619)

Changed 3 years ago by work@…

  • milestone changed from 0.6 to 0.6.2

Changed 3 years ago by t.w.abma@…

  • owner changed from t.w.abma@… to m.s.vanvliet@…

Fixed the validating error (caused by sample names not being unique) in revision 1187. Most samples from the DCL Excel sheet are imported correctly now, but when a sample name (identifier) is already in, it skips that sample.

Changed 3 years ago by m.s.vanvliet@…

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.