Ticket #20 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

save of subjects does not work

Reported by: kees.vanbochove@… Owned by:
Priority: major Milestone:
Component: Export functionality Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

The error is:

exception → org.compass.gps.device.hibernate.HibernateGpsDeviceException?: {hibernate}: Failed while creating [sd]; nested exception is org.compass.core.converter.ConversionException?: Trying to marshall a null id [id] for alias [Subject], see log for stacktrace

Change History

Changed 4 years ago by kees.vanbochove@…

The text appeared in a popup box in the final save step of the wizard. Note that some samples had no template assigned, so that might be the cause of the exception.
It seems that the Searchable plugin has problems reading the hibernate translation of the wizard flow objects.
This was seen in development mode with in-memory database.

Changed 4 years ago by j.a.m.wesbeek@…

- changed title from 'samples' to 'subjects'
- it looks like this is a known issue:  http://jira.codehaus.org/browse/GRAILSPLUGINS-1577

Changed 4 years ago by j.a.m.wesbeek@…

- temporary fix for now by disabling searchable for Subjects, svn commit #622
- now we need to wait for the searchable issue to be fixed...

Changed 4 years ago by business@…

  • status changed from new to closed
  • component set to Export functionality
Note: See TracTickets for help on using tickets.