Ticket #197 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

User creation / approval process breaks the study wizard

Reported by: work@… Owned by: robert@…
Priority: major Milestone: 0.6.1
Component: General Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

Since #188 and #189 have been implemented, the account creation process breaks the study create wizard.

Steps to reproduce:
1. create an account in the login panel
2. click confirmation link in the email
3. log in as administrator
4. start the study capture wizard (create study)

The wizard is now broken and it is caused by common/_error.gsp which uses 'flash.errors' to store a map or errors. I assume somewhere in the authentication process errors are also stored in the flash scope...

Change History

Changed 3 years ago by work@…

  • status changed from new to assigned
  • owner changed from work@… to robert@…

changed flash.errors throughout the wizard into flash.wizardErrors in r1149 so it does not break anymore if somewhere the flash.errors is used as well. However, somewhere somebody started pushing things into flash.errors as well... I think it would be best to change flash.errors into a more specific variable as well in those places. Assigning to Robert as he made the authentication parts which -I suspect- caused this to happen in the first place.

Changed 3 years ago by robert@…

  • status changed from assigned to closed
  • resolution set to fixed

I've changed it to flash.userError instead of flash.error. It's strange that it gave problems, since the authentication part used 'flash.error' and the wizard apparently 'flash.errors'.

Anyway, it works again.

Note: See TracTickets for help on using tickets.