Ticket #196 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Error when viewing contacts

Reported by: business@… Owned by: business@…
Priority: major Milestone:
Component: General Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

Choosing contacts > view persons in the menu ( http://ci.gscf.nmcdsp.org/gscf-0.6.0-ci/person/list) results in an error:

Grails Runtime Exception
Error Details
Error 500: Executing action [list] of controller [dbnp.studycapturing.PersonController?] caused exception: could not resolve property: lastName, firstName of: dbnp.studycapturing.Person; nested exception is org.hibernate.QueryException?: could not resolve property: lastName, firstName of: dbnp.studycapturing.Person
Servlet: grails
URI: /gscf-0.6.0-ci/grails/person/list.dispatch
Exception Message: could not resolve property: lastName, firstName of: dbnp.studycapturing.Person
Caused by: could not resolve property: lastName, firstName of: dbnp.studycapturing.Person
Class: PersonController?
At Line: [72]
Code Snippet:
Stack Trace

org.hibernate.QueryException?: could not resolve property: lastName, firstName of: dbnp.studycapturing.Person

at dbnp.studycapturing.PersonController?$_closure3.doCall(PersonController?.groovy:72)

at dbnp.studycapturing.PersonController?$_closure3.doCall(PersonController?.groovy)

at org.apache.jk.server.JkCoyoteHandler?.invoke(JkCoyoteHandler?.java:190)

at org.apache.jk.common.HandlerRequest?.invoke(HandlerRequest?.java:291)

at org.apache.jk.common.ChannelSocket?.invoke(ChannelSocket?.java:774)

at org.apache.jk.common.ChannelSocket?.processConnection(ChannelSocket?.java:703)

at org.apache.jk.common.ChannelSocket?$SocketConnection?.runIt(ChannelSocket?.java:896)

at java.lang.Thread.run(Thread.java:619)

Change History

Changed 3 years ago by robert@…

  • owner changed from robert@… to business@…
  • status changed from new to assigned

Fixed in the trunk. Please test again.

Changed 3 years ago by business@…

  • status changed from assigned to closed
  • resolution set to fixed

Works fine now.

Note: See TracTickets for help on using tickets.