Ticket #195 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Regenerate samples in study edit wizard after editing events

Reported by: business@… Owned by: business@…
Priority: major Milestone: 0.6.1
Component: Study create/edit wizard Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

When someone edits a study in the study edit wizard, changing sampling events and event groups, it would be nice if it were possible to regenerate the samples.
So, if sampling events, event groups or subjects have changed, the user should in the Samples step be presented with a question like 'do you want to delete the current samples [if any of course] and regenerate the samples?'

Attachments

events.png Download (64.5 KB) - added by business@… 3 years ago.
samples.png Download (25.4 KB) - added by business@… 3 years ago.
groups.png Download (60.6 KB) - added by business@… 3 years ago.
samplesfilled.png Download (86.9 KB) - added by business@… 3 years ago.
create_new_study_10humans_2samplingevents Download (2.3 KB) - added by business@… 3 years ago.
Selenium 1.0.8 testcase that reproduces some of the steps specified in the comments (don't run it too fast)

Change History

Changed 3 years ago by business@…

Actually this even occurs when still creating a study:
- Create a new study
- Add 10 Homo sapiens subjects with template human
- Specify sampling event and event groups as follows:

- Specify event group as follows:

- Go to samples step
- Go back
- Go forward again to samples step
- Now the samples are suddenly gone:

Changed 3 years ago by business@…

Changed 3 years ago by business@…

Changed 3 years ago by business@…

Changed 3 years ago by business@…

Also (following the same procedure as in the previous comment), the actual samples that were generated in the sample step the first time are not correct. There are only samples for the second group. I tried this multiple times, because I thought I made an error (that's also why I wanted to go back) but this is consistent but incorrect behaviour:

Changed 3 years ago by business@…

Changed 3 years ago by business@…

Selenium 1.0.8 testcase that reproduces some of the steps specified in the comments (don't run it too fast)

Changed 3 years ago by business@…

This was also reported in #194, closing that one as duplicate, copy (Eugene):
When creating a new study with the wizard, step 5 does not work properly, i.e. Not all samples are created (only samples of last group). I've created 7 groups with 5 subjects in each group. Each group has its own Event (NTC Compound Challenge) and all groups have the same sampling Event (Cell extraction (in vivo)). After assigning the subjects to each group and clicking next, only the samples in the last group are displayed.

Also, when clicking prev at step 5 or going back at the last step will result in no samples at all when returning to step5. This also happens when one wants to edit afterwards.

Changed 3 years ago by business@…

When editing a study, the sample step seems to be always empty.

Changed 3 years ago by work@…

  • type changed from enhancement to defect

Changed 3 years ago by work@…

  • owner changed from work@… to business@…
  • status changed from new to assigned

Resolved in r1155

- This was partly caused by the intoduction of ParentEvent? and only happened in strange situations which normally should not happen in a serious study. But of course, it should never happen.
- also extended the sample name with eventGroupName and extended the width another 50 pixels

please retest...

Changed 3 years ago by business@…

  • owner changed from business@… to e.vansomeren@…
  • cc eugene.vansomeren@… removed

Tested this with a quite elaborate example, and apart from the searchable error (fixed with [1170]) sample generation looks stable now.
Sample re-generation also looks good now!

Eugene, could you please test this too?

Changed 3 years ago by e.vansomeren@…

  • owner changed from e.vansomeren@… to business@…

Indeed, there are more samples being created, but unfortunately not all.
Please check study GSE5509 (stored under user user).
When you arrive at the page "Assign subjects to eventgroups" page, currently rat1-rat15 are assigned to the first event (T_ANI) and rat16-rat39 are assigned to (N_CAR). When clicking next, no samples will be generated for rat1-15. This is not caused by the fact that non all events are assigned (see below)

When I first reassign rat1-5 to T_ANI, rat6-10 to N_CAR, rat 11-15 to T_DMN, rat16-20 to N-DNP, rat21-25 to T_NMF, rat26-30 to N_ROS and rat31-39 to N_CON and then press next, no samples will be generated for rat1-5.

So it seems that the first group is lost.

Changed 3 years ago by work@…

  • owner changed from business@… to e.vansomeren@…

Hi Eugene,

I tried locating the study you mentioned (GSE5509) but I cannot find it in ci, test, dbnptest or dbnpdemo. Where did you try to confirm this issue was indeed resolved?

You should test any bugfixes on the continuous integration (ci) environment as that's bleeding edge...

Hence:  http://ci.nmcdsp.org

Can you please retest if this issue is indeed resolved on the ci environment? If not, please attach steps to reproduce the issue you are experiencing...

Changed 3 years ago by e.vansomeren@…

  • owner changed from e.vansomeren@… to business@…

Hmm, strange that you cannot find this study.

please go to  http://ci.nmcdsp.org/gscf-0.6.0-ci/study/myStudies
login as user "user" and you should see GSE5509 (Expression data from Rat liver 48 hours after treated with different toxic compounds).

If you click edit and 4/5 times next you will see that only rat16-rat39 are sampled.
I just checked and had this problem again.

Changed 3 years ago by e.vansomeren@…

I re-entered a completely new study GSE5509_2 and now sample creation seems to work fine. Apparently, there is something strange stored in GSE5509.

Changed 3 years ago by work@…

Hey Eugene, you're right. I was looking at the CI as Administrator but I did not see the study you created and an administrator should be able to see and do everything. However, the study didn't pop up so I'll create a new ticket for that --> #207

In the meantime, do you have any idea what you did differently between GSE5509_2 and GSE5509?

Changed 3 years ago by work@…

  • owner changed from business@… to e.vansomeren@…

Changed 3 years ago by e.vansomeren@…

  • owner changed from e.vansomeren@… to business@…

Unfortunately, I created a new study template (NTC Study 2) with text instead of string for study description and an additional field called BioinformaticsContact? and used this for GSE5509_2 (whereas I used NTC Study for GSE5509). However, I doubt that this is part of the difference.

Another difference is simply creation during older version of GSCF for GSE5509 (with the sample recreate bug). Also at creation time I tried to use more than 255 characters in the Title Description (study level) which gave some errors at the end (perhaps something was saved wrong due to that).

In GSE5509_2 I have now added contacts.

I have the feeling that perhaps group names may be involved (when you have defined events and sampling events, you can rename a group in one of the fields (bv events), but this is not immediately noticed in the fields of sampling event. This is just a feeling.

Finally, at creation of GSE5509 I was able to create an assay template Microarray, which is no longer functional in the current version.

All in all, no concrete ideas.
It's ok to close this and forget about GSE5509, but I leave it up to you.
I was just wondering if it was visible somehow in the database.

Changed 3 years ago by business@…

  • status changed from assigned to closed
  • resolution set to fixed

Thanks, Eugene and Jeroen, for working this out. It seems to me that most likely the problems were caused by the earlier version of GSCF in which the GSE5509 study was created. If in GSE5509_2 everything works now fine, I think we can close the ticket.
Also Jeroen created #207 for the non-visibility issue, so that's covered as well.
Resolving this as fixed.

Note: See TracTickets for help on using tickets.