Ticket #178 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

saveCorrectedCells breaks when importing a simple 3 column excel doc.

Reported by: m.s.vanvliet@… Owned by: work@…
Priority: major Milestone: 0.6.2
Component: Import wizard Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

Grails Runtime Exception
Error Details
Error 500: Executing action [saveCorrectedCells] of controller [dbnp.importer.ImporterController?] caused exception: For input string: "192-ontology_id"
Servlet: grails
URI: /gscf-0.6.0-test/grails/importer/saveCorrectedCells.dispatch
Exception Message: For input string: "192-ontology_id"
Caused by: For input string: "192-ontology_id"
Class: ImporterController?
At Line: [178]

Excel is 3 columns:
sample : dcl : material
...
After using the ontology chooser I get this error

Change History

Changed 3 years ago by work@…

  • milestone changed from 0.6 to 0.6.2

Changed 3 years ago by work@…

This is probably caused by the fact that Michael was copy / pasting Terms which bypassed the ontology chooser to properly dynamically fill / add the hidden fields for each term. This fix should be two-fold:

1. the importer should be able to handle terms which are empty (hidden fields are empty or not present) --> for Tjeerd to fix
2. the ontology chooser needs to either ignore the paste action, make sure the ontology chooser's autocomplete is fired that the copy / paste action also copy/pastes the hidden fields or something --> for Jeroen to fix

Changed 3 years ago by work@…

  • status changed from new to assigned

Resolved part 2 of this issue. Extended the ontology chooser in r1184 with copy / paste support. When you have selected a term from an ontology you can now copy it, and paste it in other ontology fields that accept the same ontology (ncboId) or all ontologies.

Assigning back to Tjeerd for testing (copy paste ontologies in the import wizard like Michael showed us today) and to fix part one of this issue...

Changed 3 years ago by t.w.abma@…

  • owner changed from t.w.abma@… to work@…

Will not test this for now, I actually removed the extra step where one can freely enter/correct missing ontologies. This has been replaced by a suggestion in this ticket:  https://trac.nbic.nl/gscf/ticket/140 where in the table editor one can add new ontologies and also gets a warning if an ontology is invalid. Might have to improve the appearance of the invalid ontology term via JS with the help of Jeroen?

Changed 3 years ago by s.h.sikkema@…

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.