Ticket #176 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Unable to map samples for Pilot

Reported by: m.s.vanvliet@… Owned by: m.s.vanvliet@…
Priority: blocker Milestone: 0.6.1
Component: General Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

When trying to map samples via an import I get this:

 http://localhost:8080/gscf/importer/saveCorrectedCells

.setting [class dbnp.studycapturing.Sample] (836) domain field: [name] ([sample006] of type [class java.lang.String])
.setting [class dbnp.studycapturing.Sample] (836) template field: [DCL Sample Reference] ([smpl-dcl-2010004ACA000206] of type [class java.lang.String])
2010-11-08 16:17:23,363 [http-8080-1] ERROR errors.GrailsExceptionResolver? - Cannot get property 'index' on null object
java.lang.NullPointerException?: Cannot get property 'index' on null object

at dbnp.importer.ImporterController?$_closure7.doCall(ImporterController?.groovy:163)
at dbnp.importer.ImporterController?$_closure7.doCall(ImporterController?.groovy)
at java.lang.Thread.run(Thread.java:619)

Attachments

sample_map.xls Download (23.0 KB) - added by m.s.vanvliet@… 3 years ago.
GSCF to DCL Sample mapping

Change History

Changed 3 years ago by t.w.abma@…

  • status changed from new to closed
  • resolution set to worksforme

Tested it again here, but I cannot reproduce it here. If I have an Excel file with two columns and ten rows with values (sample name and DCL reference sample name) it works here and imports it without problems. What did we do different yesterday?

Changed 3 years ago by t.w.abma@…

  • status changed from closed to reopened
  • resolution worksforme deleted

Changed 3 years ago by t.w.abma@…

  • status changed from reopened to assigned
  • owner changed from t.w.abma@… to m.s.vanvliet@…

Could you try it again?

Changed 3 years ago by m.s.vanvliet@…

  • owner changed from m.s.vanvliet@… to t.w.abma@…

For some reason It's not showing my Excel data anymore. See the file attached...

Start via :8080/gscf/pilot -> Import samples -> ...

Changed 3 years ago by m.s.vanvliet@…

GSCF to DCL Sample mapping

Changed 3 years ago by t.w.abma@…

  • owner changed from t.w.abma@… to m.s.vanvliet@…

In revision 1122 this is fixed. The importer by default shows only a maximum of five rows to give you an idea of what was imported, files with less than five rows now also show up.

Changed 3 years ago by business@…

  • milestone changed from 0.5.1 to 0.6.1

Changed 3 years ago by work@…

in r1122 that was

Changed 3 years ago by m.s.vanvliet@…

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.