Ticket #164 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Exception in create wizard when creating assay but no samples

Reported by: business@… Owned by:
Priority: minor Milestone: 0.6.1
Component: General Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

When you specify no samples in the create study wizard, but you do add an assay (should that even be allowed?), you get an exception:

2010-11-03 14:19:14,295 [TP-Processor12] ERROR view.GroovyPageView? - Error processing GroovyPageView?: Error executing tag <wizard:pageContent>: Cannot invoke method giveFields() on null object at /home/tomcat/apache-tomcat/webapps/gscf-0.5.0-ci/WEB-INF/grails-app/views/wizard/pages/_confirmation.gsp:1
org.codehaus.groovy.grails.web.taglib.exceptions.GrailsTagException?: Error executing tag <wizard:pageContent>: Cannot invoke method giveFields() on null object at /home/tomcat/apache-tomcat/webapps/gscf-0.5.0-ci/WEB-INF/grails-app/views/wizard/pages/_confirmation.gsp:1

at home_tomcat_apache_tomcat_webapps_gscf_0_5_0_ci_WEB_INF_grails_app_views_wizard_pagesconfirmation_gsp.run(home_tomcat_apache_tomcat_webapps_gscf_0_5_0_ci_WEB_INF_grails_app_views_wizard_pages__confirmation_gsp:148)
at org.apache.jk.server.JkCoyoteHandler?.invoke(JkCoyoteHandler?.java:190)
at org.apache.jk.common.HandlerRequest?.invoke(HandlerRequest?.java:291)
at org.apache.jk.common.ChannelSocket?.invoke(ChannelSocket?.java:774)
at org.apache.jk.common.ChannelSocket?.processConnection(ChannelSocket?.java:703)
at org.apache.jk.common.ChannelSocket?$SocketConnection?.runIt(ChannelSocket?.java:896)
at java.lang.Thread.run(Thread.java:619)

Caused by: java.lang.NullPointerException?: Cannot invoke method giveFields() on null object

at home_tomcat_apache_tomcat_webapps_gscf_0_5_0_ci_WEB_INF_grails_app_views_wizard_pagesconfirmation_gsp$_run_closure1_closure6.doCall(home_tomcat_apache_tomcat_webapps_gscf_0_5_0_ci_WEB_INF_grails_app_views_wizard_pages__confirmation_gsp:131)
at home_tomcat_apache_tomcat_webapps_gscf_0_5_0_ci_WEB_INF_grails_app_views_wizard_pages
confirmation_gsp$_run_closure1.doCall(home_tomcat_apache_tomcat_webapps_gscf_0_5_0_ci_WEB_INF_grails_app_views_wizard_pages__confirmation_gsp:127)
at home_tomcat_apache_tomcat_webapps_gscf_0_5_0_ci_WEB_INF_grails_app_views_wizard_pagesconfirmation_gsp$_run_closure1.doCall(home_tomcat_apache_tomcat_webapps_gscf_0_5_0_ci_WEB_INF_grails_app_views_wizard_pagesconfirmation_gsp)
at dbnp.studycapturing.WizardTagLib?$_closure4.doCall(WizardTagLib?.groovy:215)
... 7 more

2010-11-03 14:19:14,299 [TP-Processor12] ERROR errors.GrailsExceptionResolver? - Exception thrown in state 'confirm' of flow 'wizard/pages'
org.springframework.webflow.execution.FlowExecutionException?: Exception thrown in state 'confirm' of flow 'wizard/pages'

at org.apache.jk.server.JkCoyoteHandler?.invoke(JkCoyoteHandler?.java:190)
at org.apache.jk.common.HandlerRequest?.invoke(HandlerRequest?.java:291)
at org.apache.jk.common.ChannelSocket?.invoke(ChannelSocket?.java:774)
at org.apache.jk.common.ChannelSocket?.processConnection(ChannelSocket?.java:703)
at org.apache.jk.common.ChannelSocket?$SocketConnection?.runIt(ChannelSocket?.java:896)
at java.lang.Thread.run(Thread.java:619)

Caused by: java.lang.IllegalStateException?: Exception occurred rendering view org.codehaus.groovy.grails.web.servlet.view.GroovyPageView?: unnamed; URL /WEB-INF/grails-app/views//wizard/pages/_confirmation.gsp

... 6 more

Caused by: org.codehaus.groovy.grails.web.pages.exceptions.GroovyPagesException?: Error processing GroovyPageView?: Error executing tag <wizard:pageContent>: Cannot invoke method giveFields() on null object at /home/tomcat/apache-tomcat/webapps/gscf-0.5.0-ci/WEB-INF/grails-app/views/wizard/pages/_confirmation.gsp:1

... 6 more

Caused by: org.codehaus.groovy.grails.web.taglib.exceptions.GrailsTagException?: Error executing tag <wizard:pageContent>: Cannot invoke method giveFields() on null object at /home/tomcat/apache-tomcat/webapps/gscf-0.5.0-ci/WEB-INF/grails-app/views/wizard/pages/_confirmation.gsp:1

at home_tomcat_apache_tomcat_webapps_gscf_0_5_0_ci_WEB_INF_grails_app_views_wizard_pagesconfirmation_gsp.run(home_tomcat_apache_tomcat_webapps_gscf_0_5_0_ci_WEB_INF_grails_app_views_wizard_pages__confirmation_gsp:148)
... 6 more

Caused by: java.lang.NullPointerException?: Cannot invoke method giveFields() on null object

at home_tomcat_apache_tomcat_webapps_gscf_0_5_0_ci_WEB_INF_grails_app_views_wizard_pagesconfirmation_gsp$_run_closure1_closure6.doCall(home_tomcat_apache_tomcat_webapps_gscf_0_5_0_ci_WEB_INF_grails_app_views_wizard_pages__confirmation_gsp:131)
at home_tomcat_apache_tomcat_webapps_gscf_0_5_0_ci_WEB_INF_grails_app_views_wizard_pages
confirmation_gsp$_run_closure1.doCall(home_tomcat_apache_tomcat_webapps_gscf_0_5_0_ci_WEB_INF_grails_app_views_wizard_pages__confirmation_gsp:127)
at home_tomcat_apache_tomcat_webapps_gscf_0_5_0_ci_WEB_INF_grails_app_views_wizard_pagesconfirmation_gsp$_run_closure1.doCall(home_tomcat_apache_tomcat_webapps_gscf_0_5_0_ci_WEB_INF_grails_app_views_wizard_pagesconfirmation_gsp)
at dbnp.studycapturing.WizardTagLib?$_closure4.doCall(WizardTagLib?.groovy:215)
... 7 more

Change History

Changed 3 years ago by business@…

Also, in step 3, the wizard should validate the entries first and give an error message if they do not validate (otherwise '0 of 10 imported' will result).

Changed 3 years ago by business@…

  • milestone set to 0.6.1

This is probably caused by using the 'back' button after importing, it then looks like the wizard works, but it will return this error.

Changed 3 years ago by work@…

  • status changed from new to closed
  • resolution set to duplicate

This issue was also reported as duplicate issue #167, as the latter contains more information I will close this issue for now...

Note: See TracTickets for help on using tickets.