Ticket #160 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Grom plugin breaks on tomcat when deployed as a war

Reported by: work@… Owned by: work@…
Priority: major Milestone:
Component: General Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware: All

Description

On tomcat the plugin results in the following error:

2010-11-01 11:33:23,154 [ContainerBackgroundProcessor?[StandardEngine?[Catalina]]] ERROR plugins.DefaultGrailsPluginManager? - Error configuring dynamic methods for plugin [grom:0.1.8]: java.lang.NoClassDefFoundError?: org.codehaus.gant.GantBuilder?
org.codehaus.groovy.runtime.InvokerInvocationException?: java.lang.NoClassDefFoundError?: org.codehaus.gant.GantBuilder?
at java.lang.Thread.run(Thread.java:619)
Caused by: java.lang.NoClassDefFoundError?: org.codehaus.gant.GantBuilder?
at GromGrailsPlugin?$_closure3.class$(GromGrailsPlugin?.groovy)
at GromGrailsPlugin?$_closure3.$get$$class$org$codehaus$gant$GantBuilder?(GromGrailsPlugin?.groovy)
at GromGrailsPlugin?$_closure3.doCall(GromGrailsPlugin?.groovy:33)
... 1 more

see:  http://jira.codehaus.org/browse/GRAILS-6900

Change History

Changed 3 years ago by work@…

  • status changed from new to closed
  • resolution set to fixed

I have refactored the plugin to not use gant/ant. Because native command line execution methods do not work properly with the external 'growlnotify' binary, I have written an applescript that does the same and does work with the regular execute methods. In the meantime the grails issue raised above was also labeled as 'wont fix':

"Graeme Rocher added a comment - 02/Nov/10 7:59 AM
In general the fact that GantBuilder? is available when the application is deployed as a WAR or during run-app is a bug. Gant is a build time only dependency and it is a side effect of another bug that it is available to you. If you want these to work you'll have to include gant as a compile time dependency of your plugin"

Including ant will result in KB's of extra overhead, and it should be a small-footprint plugin. Therefore, goodbye gant / ant, hello applescript ;)

Note: linux support has been disabled for now, to be enabled in the future...

Note: See TracTickets for help on using tickets.