Ticket #149 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

termEditor autocomplete recently started escaping span elements in result entries

Reported by: work@… Owned by: work@…
Priority: minor Milestone: 0.5.1
Component: General Version:
Keywords: termEditor jquery jquery-ui Cc:
Hardware: Operating system:
Product: URL:


probably related to the recent upgrade of the jquery plugin and the jquery-ui code...

Change History

comment:1 Changed 5 years ago by work@…

  • Milestone set to 0.5.1

comment:2 Changed 5 years ago by work@…

After more in-depth investigation it turns out things stopped working in jquery-ui 1.8.3 while they were working in 1.8.2.

As stated by http://wiki.jqueryui.com/Autocomplete, the autocomplete requires an array of objects (maps), containing two required properties:

  • A label property to display in the autocomplete list ("John Doe <john@…>").

o This can be HTML markup, if a seperate markup-free value is specified.mac data recovery

  • A value property that ends up in the input field once selected ("john@…");

o if undefined, same as label
o this must be plain-text (no markup)

However, when the label contains markup, the markup is being escaped since jquery-ui 1.8.3 and hence the markup is lost

comment:3 Changed 5 years ago by work@…

Filed a jquery-ui bugreport; see: http://dev.jqueryui.com/ticket/6235

comment:4 Changed 5 years ago by work@…

  • Status changed from new to accepted

comment:5 Changed 5 years ago by work@…

  • Status changed from accepted to closed
  • Resolution set to fixed

Apparently the change to escape HTML was done by design and hence not a bug, but a feature. I included the jquery-ui autocomplete extension to allow HTML as a label from http://github.com/scottgonzalez/jquery-ui-extensions/tree/master/autocomplete/

Resolved in svn commit 1005

Note: See TracTickets for help on using tickets.