Ticket #147 (closed defect: worksforme)

Opened 3 years ago

Last modified 3 years ago

Edit study wizard doesn't work anymore

Reported by: business@… Owned by: kees.vanbochove@…
Priority: major Milestone: 0.5.1
Component: Study create/edit wizard Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

Since Grails 1.3.5, the edit study wizard stops functioning after the first step. See  http://jira.codehaus.org/browse/GRAILS-6863.

Change History

Changed 3 years ago by work@…

  • status changed from new to assigned
  • owner changed from j.a.m.wesbeek@… to work@…
  • component changed from GSCF in general to Study create/edit wizard

Changed 3 years ago by business@…

On Grails 1.3.4 it works, but an error message is displayed: exception → Cannot invoke method getLoggedInUser() on null object, see log for stacktrace

Changed 3 years ago by business@…

Investigate bug

Changed 3 years ago by business@…

Might help to put transient in front of definition

Changed 3 years ago by work@…

  • owner changed from work@… to Robert@…

Assigning to Robert as this is now caused by the authentication service in grails 1.3.4. We can look together at this perhaps?

Changed 3 years ago by robert@…

  • owner changed from Robert@… to business@…

The authentication had been fixed last week, but was broken again due to a commit of application.properties with grails version 1.3.5. THis problem is fixed now, and the editing of studies works again.

Changed 3 years ago by business@…

  • status changed from assigned to closed
  • resolution set to worksforme

Works again thanks to reverting to 1.3.4.

Changed 3 years ago by work@…

  • status changed from closed to reopened
  • resolution worksforme deleted

Changed 3 years ago by work@…

  • owner changed from business@… to kees.vanbochove@…
  • status changed from reopened to assigned

The Edit study wizard is now also working with Grails 1.3.5 after resolving issue #223 in changelist r1225 :D

Changed 3 years ago by work@…

Can you please retest / confirm Kees? :D

Changed 3 years ago by business@…

Hmm... the very first time I tried it, I got an error. But after that, it worked. Also in other browsers, it works. So probably that first time was due to caching or something like that. I did find an accompanying error in the log:

2010-12-02 13:50:10,856 [TP-Processor6] ERROR errors.GrailsExceptionResolver  - A problem occurred restoring the flow execution with key 'e3s2'
org.springframework.webflow.execution.repository.FlowExecutionRestorationFailureException: A problem occurred restoring the flow execution with key 'e3s2'
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:774)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:896)
	at java.lang.Thread.run(Thread.java:619)
Caused by: org.springframework.webflow.execution.repository.snapshot.SnapshotUnmarshalException: IOException thrown deserializing the flow execution stored in this snapshot -- this should not happen!
	... 6 more
Caused by: java.io.InvalidObjectException: Javassist Enhancement failed: dbnp.studycapturing.Template
	at java.io.ObjectStreamClass.invokeReadObject(ObjectStreamClass.java:974)
	at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1849)
	at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1753)
	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1329)
	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:351)
	at java.util.HashMap.readObject(HashMap.java:1030)
	at java.io.ObjectStreamClass.invokeReadObject(ObjectStreamClass.java:974)
	at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1849)
	at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1753)
	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1329)
	at java.io.ObjectInputStream.defaultReadFields(ObjectInputStream.java:1947)
	at java.io.ObjectInputStream.defaultReadObject(ObjectInputStream.java:480)
	at java.io.ObjectStreamClass.invokeReadObject(ObjectStreamClass.java:974)
	at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1849)
	at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1753)
	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1329)
	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:351)
	at java.io.ObjectInputStream.readExternalData(ObjectInputStream.java:1792)
	at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1751)
	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1329)
	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:351)
	at java.util.LinkedList.readObject(LinkedList.java:964)
	at java.io.ObjectStreamClass.invokeReadObject(ObjectStreamClass.java:974)
	at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1849)
	at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1753)
	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1329)
	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:351)
	at java.io.ObjectInputStream.readExternalData(ObjectInputStream.java:1792)
	at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1751)
	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1329)
	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:351)
	... 6 more

It's hard to make something out of this. I will see if I can ask anyone else to test.

Changed 3 years ago by business@…

  • status changed from assigned to closed
  • resolution set to worksforme

Tjeerd also could not reproduce this issue anymore. So closing this.

Note: See TracTickets for help on using tickets.