Ticket #137 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Error when comparing two studies in v0.5.0

Reported by: e.vansomeren@… Owned by: e.vansomeren@…
Priority: major Milestone: 0.5.1
Component: General Version: 0.5
Keywords: compare studies Cc:
Product: Operating system: Windows XP
URL: Hardware: PC

Description

When viewing studies.
Select first two studies and press "compare selected studies".
This will result in the error below.

Interestingly, I've just created a new study template (NTC) with Experiment ID as required field and added a few studies. So, although the selected studies were not created under that template, it seems that this template has an influence.

I've used v0.5.0 via dbnp.org on Windows XP using Chrome.

Grails Runtime Exception
Error Details
Error 500: Error processing GroovyPageView?: Field Experiment ID not recognized
Servlet: grails
URI: /gscf-0.5.0-demo/grails/study/list_extended.dispatch
Exception Message: Field Experiment ID not recognized
Caused by: Error processing GroovyPageView?: Field Experiment ID not recognized
Class: gsp_gscf_studyshow_gsp
At Line: [900]
Code Snippet:
Stack Trace
org.codehaus.groovy.grails.web.pages.exceptions.GroovyPagesException?: Error processing GroovyPageView?: Field Experiment ID not recognized

at net.bull.javamelody.JspWrapper?.invoke(JspWrapper?.java:116)

at net.bull.javamelody.JdbcWrapper?$DelegatingInvocationHandler?.invoke(JdbcWrapper?.java:250)

at $Proxy30.forward(Unknown Source)

at org.apache.shiro.web.servlet.ShiroFilter?.executeChain(ShiroFilter?.java:687)

at org.apache.shiro.web.servlet.ShiroFilter?.doFilterInternal(ShiroFilter?.java:616)

at org.apache.shiro.web.servlet.OncePerRequestFilter?.doFilter(OncePerRequestFilter?.java:81)

at net.bull.javamelody.MonitoringFilter?.doFilter(MonitoringFilter?.java:388)

at org.apache.jk.server.JkCoyoteHandler?.invoke(JkCoyoteHandler?.java:190)

Change History

Changed 3 years ago by work@…

related to #155

Changed 3 years ago by business@…

  • owner set to robert@…
  • status changed from new to assigned

Changed 3 years ago by robert@…

  • owner changed from robert@… to e.vansomeren@…

This bug has been fixed today. Please test

Changed 3 years ago by e.vansomeren@…

Thanks for the fix.

Unfortunately, I cannot test this because I cannot see any study at all (nor any new study I create) in the following version:

 http://gscf.nmcdsp.org/gscf-0.5.0-ci/
(continuous integration build of gscf 0.5.0 (svn revision: 1027, deployed at: 201011011244).)

Changed 3 years ago by robert@…

That's probably because authentication has been implemented in this version. You have to login first with username 'user' and password 'useR123!'.

I have also resolved a few other bugs with this view, so you might want to wait until a new build has been made.

Changed 3 years ago by e.vansomeren@…

Ok, when I login in with indicated username and password (thanks) I do see studies, but when I select the first two and press "Compare Selected Studies" I get the following error again (I used via Google Chrome the GSCF continuous integration build of gscf 0.5.0 (svn revision: 1027, deployed at: 201011011244).):

Grails Runtime Exception
Error Details
Error 500: Error processing GroovyPageView?: Cannot get property 'username' on null object
Servlet: grails
URI: /gscf-0.5.0-ci/grails/study/list_extended.dispatch
Exception Message: Cannot get property 'username' on null object
Caused by: Error processing GroovyPageView?: Cannot get property 'username' on null object
Class: gsp_gscf_studyshow_gsp
At Line: [897]
Code Snippet:

Stack Trace

Org.codehaus.groovy.grails.web.pages.exceptions.GroovyPagesException?: Error processing GroovyPageView?: Cannot get property 'username' on null object

at org.apache.jk.server.JkCoyoteHandler?.invoke(JkCoyoteHandler?.java:190)

at org.apache.jk.common.HandlerRequest?.invoke(HandlerRequest?.java:291)

at org.apache.jk.common.ChannelSocket?.invoke(ChannelSocket?.java:774)

at org.apache.jk.common.ChannelSocket?.processConnection(ChannelSocket?.java:703)

at org.apache.jk.common.ChannelSocket?$SocketConnection?.runIt(ChannelSocket?.java:896)

at java.lang.Thread.run(Thread.java:619)

Caused by: java.lang.NullPointerException?: Cannot get property 'username' on null object

at gsp_gscf_studyshow_gsp$_run_closure2_closure15.doCall(gsp_gscf_studyshow_gsp.groovy:256)

at gsp_gscf_studyshow_gsp$_run_closure2.doCall(gsp_gscf_studyshow_gsp.groovy:254)

at gsp_gscf_studyshow_gsp$_run_closure2.doCall(gsp_gscf_studyshow_gsp.groovy)

at gsp_gscf_studyshow_gsp.run(gsp_gscf_studyshow_gsp.groovy:897)

... 6 more

Changed 3 years ago by robert@…

As I said, "I have also resolved a few other bugs with this view, so you might want to wait until a new build has been made."

Currently a new build is available at the CI machine, and when I test it there, it works for me. Would you test it again?

Changed 3 years ago by e.vansomeren@…

I'm not sure what you mean with CI machine, but for me it works fine on  http://gscf.nmcdsp.org/gscf-0.5.0-ci/study/list

Thanks!

I'll try to add my own studies (e.g. with a different template) and test it further.

Changed 3 years ago by e.vansomeren@…

Works fine!
I've created two studies (via wizard) under my own username, using two different templates.
Comparing the two studies works fine!

From my side we may close this ticket.

Changed 3 years ago by business@…

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.