Ticket #135 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

[wizard] All data is returned in a random order

Reported by: j.a.m.wesbeek@… Owned by: work@…
Priority: major Milestone: 0.5.1
Component: Study create/edit wizard Version:
Keywords: Cc:
Product: Operating system: MacOS X
URL: Hardware: Macintosh

Description

Currently, all data on pages is randomized. For example, subjects, events, assays and samples are displayed in a random order after a next page request. This is caused by GORM returning data in a random order.

Todo: make sure the data is returned in a similar order, every time, all the time.

Change History

Changed 3 years ago by business@…

For subjects this is already resolved, they always appear in the same order.
Events do too, but only if you use the each closure for all events. If you use Study.giveAllEventTemplates() to order them on templates, the order of the templates will be random. So todo: adjust that function and also TemplateEntity?.giveTemplates() to return templates in sorted order (by name).
The same goes for assays and samples, they will be sorted (but only if the samples are generated in a non-random order, because the sorting is on moment of creation), and the templates will be after adjustment of these functions.

Changed 3 years ago by work@…

  • owner changed from business@… to work@…
  • status changed from new to assigned
  • component changed from GSCF in general to Study create/edit wizard

Changed 3 years ago by business@…

  • owner changed from work@… to robert@…

Changed 3 years ago by robert@…

  • owner changed from robert@… to j.a.m.wesbeek@…

This issue is fixed for all places where templates are fetched from the database. Please retest.

Changed 3 years ago by work@…

  • owner changed from j.a.m.wesbeek@… to work@…

Changed 3 years ago by work@…

  • status changed from assigned to closed
  • resolution set to fixed

works for me...

Note: See TracTickets for help on using tickets.