Ticket #130 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

SimpleTox exporter

Reported by: business@… Owned by: adem.bilican@…
Priority: major Milestone: 0.6.1
Component: Export functionality Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description (last modified by business@…) (diff)

We need a SimpleTox? exporter to get metadata into ArrayTrack?. This is an Excel sheet format, which is filled by iterating over the samples in the study.
The first columns are fixed and can be filled with data from the Samples as shown below:


The rest of the columns should be filled with the following data:

  • all Subject domain+template properties from Sample.parentSubject
  • all SamplingEvent? domain+template properties from Sample.parentEvent
  • all Event domain+template properties for all Events in Sample.parentEventGroup (NB: that one still has to be implemented)
  • all Sample domain+template properties

Attachments

SimpleTox mapping.png Download (26.0 KB) - added by business@… 3 years ago.

Change History

Changed 3 years ago by business@…

  • owner set to adem.bilican@…
  • status changed from new to assigned
  • component changed from GSCF in general to Export functionality

Changed 3 years ago by business@…

Changed 3 years ago by business@…

  • description modified (diff)

Changed 3 years ago by business@…

After the file is created, the user should be presented with a download page where the resulted file can be downloaded!

Changed 3 years ago by e.vansomeren@…

Hi, Thanks for creating the exporter.
However, it only works for the first two studies.
If I select the third study, I get the following error:
(Google Chrome on Windows XP on  http://gscf.nmcdsp.org/gscf-0.5.0-ci/exporter/export)

Grails Runtime Exception

Error Details

Error 500: Executing action [export] of controller [dbnp.exporter.ExporterController?] caused exception: null
Servlet: grails
URI: /gscf-0.5.0-ci/grails/exporter/export.dispatch
Exception Message:
Caused by:
Class: ExporterController?
At Line: [110]
Code Snippet:
Stack Trace
java.lang.NullPointerException?

at dbnp.exporter.ExporterController?$_closure2.doCall(ExporterController?.groovy:110)

at dbnp.exporter.ExporterController?$_closure2.doCall(ExporterController?.groovy)

at org.apache.jk.server.JkCoyoteHandler?.invoke(JkCoyoteHandler?.java:190)

at org.apache.jk.common.HandlerRequest?.invoke(HandlerRequest?.java:291)

at org.apache.jk.common.ChannelSocket?.invoke(ChannelSocket?.java:774)

at org.apache.jk.common.ChannelSocket?.processConnection(ChannelSocket?.java:703)

at org.apache.jk.common.ChannelSocket?$SocketConnection?.runIt(ChannelSocket?.java:896)

at java.lang.Thread.run(Thread.java:619)

Changed 3 years ago by adem.bilican@…

  • status changed from assigned to closed
  • resolution set to fixed

Exporting as SimpleTox? works good :
- EventGroup? properties missing (not implemented yet in domain classes)
- creating a ZIP file if multiple studies are selected

Note: See TracTickets for help on using tickets.