Ticket #126 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

exception after importing subjects sheet

Reported by: business@… Owned by: work@…
Priority: blocker Milestone: 0.6.1
Component: Import wizard Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

After importing the example subjects sheet, I got an error:  http://demo.dbnp.org/gscf-0.5.0-demo/importer/savePostview

Grails Runtime Exception
Error Details
Error 500: Executing action [savePostview] of controller [dbnp.importer.ImporterController?] caused exception: null identifier
Servlet: grails
URI: /gscf-0.5.0-demo/grails/importer/savePostview.dispatch
Exception Message: null identifier
Caused by: null identifier
Class: ImporterController?
At Line: [272]
Code Snippet:
Stack Trace

org.hibernate.AssertionFailure?: null identifier

at dbnp.importer.ImporterService?.saveDatamatrix(ImporterService?.groovy:245)

at dbnp.importer.ImporterService?$$FastClassByCGLIB$$3550d3b5.invoke(<generated>)

at net.sf.cglib.proxy.MethodProxy?.invoke(MethodProxy?.java:149)

at dbnp.importer.ImporterService?$$EnhancerByCGLIB$$5baed70a.saveDatamatrix(<generated>)

at GrailsMelodyGrailsPlugin?$_closure5_closure18_closure19.doCall(GrailsMelodyGrailsPlugin?.groovy:156)

at dbnp.importer.ImporterController?$_closure9.doCall(ImporterController?.groovy:272)

at dbnp.importer.ImporterController?$_closure9.doCall(ImporterController?.groovy)

at net.bull.javamelody.JspWrapper?.invoke(JspWrapper?.java:116)

at net.bull.javamelody.JdbcWrapper?$DelegatingInvocationHandler?.invoke(JdbcWrapper?.java:250)

at $Proxy30.forward(Unknown Source)

at org.apache.shiro.web.servlet.ShiroFilter?.executeChain(ShiroFilter?.java:687)

at org.apache.shiro.web.servlet.ShiroFilter?.doFilterInternal(ShiroFilter?.java:616)

at org.apache.shiro.web.servlet.OncePerRequestFilter?.doFilter(OncePerRequestFilter?.java:81)

at net.bull.javamelody.MonitoringFilter?.doFilter(MonitoringFilter?.java:388)

at org.apache.jk.server.JkCoyoteHandler?.invoke(JkCoyoteHandler?.java:190)

at org.apache.jk.common.HandlerRequest?.invoke(HandlerRequest?.java:291)

at org.apache.jk.common.ChannelSocket?.invoke(ChannelSocket?.java:769)

at org.apache.jk.common.ChannelSocket?.processConnection(ChannelSocket?.java:698)

at org.apache.jk.common.ChannelSocket?$SocketConnection?.runIt(ChannelSocket?.java:891)

at java.lang.Thread.run(Thread.java:619)

Change History

Changed 4 years ago by business@…

This works with a local installation.

Changed 4 years ago by business@…

  • milestone set to 0.5.1

Changed 3 years ago by business@…

  • status changed from new to assigned
  • owner set to business@…

Changed 3 years ago by business@…

  • milestone changed from 0.5.1 to 0.6.1

This was probably caused by using the 'back' button of the browser after importing.

Changed 3 years ago by business@…

  • owner changed from business@… to t.w.abma@…

The sentence 'go back to the page where you came from' can be deleted. It results in a error when clicked.

Changed 3 years ago by business@…

disable the back link in the user interface

Changed 3 years ago by work@…

  • owner changed from t.w.abma@… to work@…

Changed 3 years ago by work@…

  • owner changed from work@… to t.w.abma@…

I still get an exception when calling the initial URL directly:  http://localhost:8080/gscf/importer/savePostview

Exception is:
Error 500: Executing action [savePostview] of controller [dbnp.importer.ImporterController?] caused exception: Cannot invoke method refresh() on null object
Servlet: grails
URI: /gscf/grails/importer/savePostview.dispatch
Exception Message: Cannot invoke method refresh() on null object
Caused by: Cannot invoke method refresh() on null object
Class: ImporterController?
At Line: [336]
Code Snippet:

Even when this is an entry point for an end-user, the code should be watertight and not result in exceptions... Assigning back to Tjeerd for fixing.

Changed 3 years ago by t.w.abma@…

  • owner changed from t.w.abma@… to work@…

Solved in revision 1191, calling savePostview url directly gives a warning now that the data already have been imported and/or that the import wizard steps should be followed from the beginning.

Changed 3 years ago by work@…

  • owner changed from work@… to t.w.abma@…

still getting the exception in HEAD...

Changed 3 years ago by t.w.abma@…

  • owner changed from t.w.abma@… to work@…

Was fixed last Tuesday, tested it locally and on CI and gives a more attractive warning.

Changed 3 years ago by s.h.sikkema@…

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.