Changes between Version 7 and Version 8 of t2web


Ignore:
Timestamp:
May 10, 2012, 11:26:23 AM (5 years ago)
Author:
kostas.karasavvas@…
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • t2web

    v7 v8  
    2121== Installation and Requirements ==
    2222The web application is implemented in Ruby, so a Ruby development environment needs to be available. Native packages of libxml, libopenssl and zlib may be required. Please use your favorite package manager to install them (an apt-get example is given). Note that some of the following native packages might already be installed in your system. For Debian-based systems, use this command:
     23{{{
    2324  $ sudo apt-get install ruby rubygems gcc build-essential libxml-ruby libopenssl-ruby libxml2-dev zlib1g-dev
    24 
     25}}}
    2526To install the taverna web interface generator you only need the following command:
     27{{{
    2628  $ sudo gem install t2-web
    27 
     29}}}
    2830
    2931== Testing ==
    3032Start the web application by typing:
    31 
     33{{{
    3234  $ cd `gem environment gemdir`/gems/t2-web-0.1.9/bin ; thin -p 9595 start
    33 
    34 Soon we will provide an executable to automate running the webapp.
     35}}}
     36Soon we will provide an executable to make running the webapp easier.
    3537
    3638