Show
Ignore:
Timestamp:
14-12-10 12:23:37 (3 years ago)
Author:
kostas.karasavvas@…
Message:

changed version to 0.1 -- added warning on generated tool's help

Files:
1 modified

Legend:

Unmodified
Added
Removed
  • galaxy-taverna/workflow-to-galaxy/lib/workflow-to-galaxy/generator.rb

    r66 r71  
    106106    end 
    107107 
    108  
    109108    out.write "-----\n\n" 
    110     out.write "For more information on that workflow please visit #{me_rest.uri.gsub(/(.*workflows\/\d+)[\/.].*/, '\1')}.\n" 
     109    out.write ".. class:: warningmark\n\n" 
     110    out.write "**Please note that some workflows are not up-to-date or have dependencies** " << 
     111              "that cannot be met by the specific Taverna server that you specified during " << 
     112              "generation of this tool. You can make sure that the workflow is valid " << 
     113              "by running it in the Taverna Workbench first to confirm that it works " << 
     114              "before running it via Galaxy.\n\n" 
     115 
     116 
     117    out.write "-----\n\n" 
     118    out.write ".. class:: infomark\n\n" 
     119    out.write "**For more information on that workflow please visit** #{me_rest.uri.gsub(/(.*workflows\/\d+)[\/.].*/, '\1')}.\n\n" 
    111120 
    112121    out.write "#{INDENT}</help>\n"