Ticket #67 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Adding of platforms (still) does not work

Reported by: work@… Owned by:
Priority: major Milestone:
Component: Measurement Platform interface Version:
Keywords: Cc:

Description

try to add a platform and you'll get an exception in the console / log (reproducible on ci):

2012-04-02 13:31:48,944 [http-8081-6] ERROR errors.GrailsExceptionResolver  - Exception occurred when processing request: [POST] /metabolomicsModule-0.2.1-ci/measurementPlatform/add
Stacktrace follows:
groovy.lang.MissingMethodException: No signature of method: org.grails.datastore.gorm.validation.constraints.UniqueConstraint$_withManualFlushMode_closure2.doCall() is applicable for argument types: ($Proxy36) values: [SessionImpl(PersistenceContext[entityKeys=[EntityKey[org.dbxp.moduleBase.Auth#168], EntityKey[org.dbxp.moduleBase.Auth#168871], EntityKey[org.dbxp.moduleBase.Auth#136], EntityKey[org.dbxp.moduleBase.Auth#1439], EntityKey[org.dbxp.moduleBase.Auth#168840], EntityKey[org.dbxp.moduleBase.User#120], EntityKey[org.dbxp.moduleBase.Auth#1498], EntityKey[org.dbxp.moduleBase.Auth#1438], EntityKey[org.dbxp.moduleBase.Auth#1497], EntityKey[org.dbxp.moduleBase.Auth#1496], EntityKey[org.dbxp.moduleBase.Auth#1440], EntityKey[org.dbxp.moduleBase.Auth#85655], EntityKey[org.dbxp.moduleBase.Auth#1442], EntityKey[org.dbxp.moduleBase.Auth#124], EntityKey[org.dbxp.moduleBase.Auth#85658], EntityKey[org.dbxp.moduleBase.Auth#85657]],collectionKeys=[CollectionKey[org.dbxp.moduleBase.User.auth#120]]];ActionQueue[insertions=[] updates=[] deletions=[] collectionCreations=[] collectionRemovals=[] collectionUpdates=[]])]
Possible solutions: doCall(org.grails.datastore.mapping.core.Session), call(), call([Ljava.lang.Object;), call(java.lang.Object), call(org.grails.datastore.mapping.core.Session), equals(java.lang.Object)
	at $Proxy35.doInHibernate(Unknown Source)
	at org.grails.datastore.gorm.validation.constraints.UniqueConstraint.withManualFlushMode(UniqueConstraint.groovy:103)
	at org.grails.datastore.gorm.validation.constraints.UniqueConstraint$withManualFlushMode.callCurrent(Unknown Source)
	at org.grails.datastore.gorm.validation.constraints.UniqueConstraint.processValidate(UniqueConstraint.groovy:39)
	at org.dbxp.metabolomicsModule.measurements.MeasurementPlatformController$_closure4.doCall(MeasurementPlatformController.groovy:45)
	at org.dbxp.metabolomicsModule.measurements.MeasurementPlatformController$_closure4.doCall(MeasurementPlatformController.groovy)
	at java.lang.Thread.run(Thread.java:662)

Change History

Changed 2 years ago by work@…

  • status changed from new to closed
  • resolution set to fixed

The cause of this issue seems to be a bit unclear. We are getting the impression Grails keeps updating Spring, which perhaps caused issues in Hibernate? In any case, all problems seemed to go away when we upgraded the application to Grails 2.0.1 in r271.

Note: See TracTickets for help on using tickets.