Ticket #21 (closed defect: fixed)

Opened 2 years ago

Last modified 22 months ago

Make it Spring 3 compatible

Reported by: hailiang.mei@… Owned by: singh.bharat@…
Priority: major Milestone:
Component: Professionalization (improve code quality) Version:
Keywords: Cc:
Product: Operating system:
URL: Hardware:

Description

Incompatibility of Spring 3 and Spring 2.5.6 on RMI. We should update the dependence.

Change History

Changed 2 years ago by hailiang.mei@…

  • summary changed from Make to Make it Spring 3 compatible

Changed 2 years ago by hailiang.mei@…

  • owner set to singh.bharat@…
  • status changed from new to assigned

Changed 22 months ago by singh.bharat@…

  • status changed from assigned to closed
  • resolution set to fixed

The client code (built on spring 3.0 +) using the data-mining project (built on spring 2.5.6) needs to include this jar in their POM file.
<dependency>

<groupId>org.springframework</groupId>
<artifactId>rmi-compatibility</artifactId>
<version>2.5.6</version>
<classifier>compatibility</classifier>

</dependency>

This jar has been created and uploaded to the NBIC nexus repository and is available at this  URL.
This is a known Spring issue, for an explanation see  this post.

Note: See TracTickets for help on using tickets.